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All rights reserved. No part of this publication may be reproduced in any form or by any electronic or mechanical means, 
including photocopying and recording, without permission in writing from GE Fanuc Automation Americas, Inc..

Disclaimer of Warranties and Liability

The information contained in this manual is believed to be accurate and reliable. However, GE Fanuc Automation Americas, 
Inc. assumes no responsibilities for any errors, omissions or inaccuracies whatsoever. Without limiting the foregoing, GE Fanuc 
Automation Americas, Inc. disclaims any and all warranties, expressed or implied, including the warranty of merchantability 
and fitness for a particular purpose, with respect to the information contained in this manual and the equipment or software 
described herein. The entire risk as to the quality and performance of such information, equipment and software, is upon the 
buyer or user. GE Fanuc Automation Americas, Inc. shall not be liable for any damages, including special or consequential 
damages, arising out of the use of such information, equipment and software, even if GE Fanuc Automation Americas, Inc. has 
been advised in advance of the possibility of such damages. The use of the information contained in the manual and the 
software described herein is subject to GE Fanuc Automation Americas, Inc. standard license agreement, which must be 
executed by the buyer or user before the use of such information, equipment or software.

Notice

GE Fanuc Automation Americas, Inc. reserves the right to make improvements to the products described in this publication at 
any time and without notice.

© 2005 GE Fanuc Automation Americas, Inc. All rights reserved. Proficy is a trademark of GE Fanuc Automation. Any other 
trademarks referenced herein are used solely for purposes of identifying compatibility with the products of GE Fanuc 
Automation Americas, Inc.

We want to hear from you. If you have any comments, questions, or suggestions about our documentation, send them to the 
following e-mail address:

doc@gefanuc.com
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1 Welcome
Congratulations on your purchase of Proficy™ Logic Developer - PLC, the 
PACSystems™ Controller and GE Fanuc PLC programming component of 
Proficy™ Machine Edition automation software.1 

This software package provides all the tools necessary to create powerful control 
applications. Logic Developer - PLC provides a way to configure your PLC 
hardware or remote I/O, create and edit logic, upload and download projects, and 
monitor and debug the execution of control programs. Projects can be imported 
from Logicmaster, VersaPro, and CimplicityControl folders.

Hosted in the Machine Edition environment, Logic Developer - PLC takes 
advantage of a powerful set of common programming tools (see page 17). The 
same tools can be applied to Logic Developer - PC (PC Control), Logic Developer - 
State, View and Motion components, providing a single programming 
environment. The Machine Edition environment unites and organizes components, 
providing data sharing and networked operation.

The following features are included in this version of Logic Developer - PLC:

■ Hardware Configuration. See page 49.

■ LD Editor. See page 83.

■ FBD Editor. See page 97.

■ IL Editor. See page 108.

■ ST Editor. See page 115.

■ C Blocks. See page 123.

■ C Programs. See page 125.

■ PLC Motion Editor. See page 133.

■ Local Logic Editor. See page 137. 

■ CAM Editor. See page 142.

1.  “PLC” is used throughout this manual to include PACSystems™ Controllers, 
Series 90™ PLCs, and VersaMax™ PLCs.
Proficy™ Logic Developer - PLC 5.50 1
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W e l c o m e
System Requirements
S Y S T E M  R E Q U I R E M E N T S
To use Logic Developer - PLC and its tools, you require the following:

■ Windows® XP Professional (Service Pack 1 recommended.)

- or -

Windows 2000 Professional (Service Pack 3 recommended.)

- or -

Windows NT version 4.0 with service pack 6.0a or later

Note: Windows XP Tablet PC Edition is not supported.
■ Internet Explorer version 5.5 with Service Pack 2 Q810847 or later, or Internet 

Explorer version 6.0 Service Pack 1 or later. 

Note: You must install Internet Explorer before installing Machine Edition.)

■ TCP/IP Network protocol-based computer (if you use an Ethernet connection).
■ Requirements for processor speed and memory are as follows:

✐ Minimum: 1 GHz Pentium-based processor with 256 MB RAM 
✐ Recommended: 2 GHz Pentium-based processor with 512 MB RAM 
✐ Note: For projects with more than 75,000 variables or variable elements, at 

least 1 GB of RAM is strongly recommended.

■ 150-750 MB free hard disk space depending on the installed products.

■ 110 MB additional hard disk space, plus 40 MB during installation, for 
Microsoft .NET Framework 1.1. This space is not needed if .NET Framework 1.1 
is already installed.

Tip: If the Microsoft .NET Framework is not yet installed, it is automatically 
included during installation of Machine Edition. 

Note: After installation of Machine Edition and the .NET Framework is 
complete, do not attempt to install an older or beta version of the .NET 
Framework. This will cause the newest version of the .NET Framework to fail. 

■ 200 MB hard disk space for sample projects (optional).

■ Additional hard disk space for projects and temporary files.
GFK-1918G Proficy™ Logic Developer - PLC 5.50 3
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Installation1
I N S T A L L A T I O N
For last-minute information, release notes, and supported hardware lists for 
Machine Edition products, see the Important Product Information (IPI) document 
on the CD. There are several ways to view this document

■ When installing Machine Edition, select Important Product Information on the 
initial Launcher screen.

■ When running Machine Edition, from the Help menu, choose Important 
Product Information.

If you have a previous version of Machine Edition installed on your computer, you 
must uninstall it before installing the latest version. You can do so by selecting the 
“Uninstall CIMPLICITY Machine Edition” option from the CIMPLICITY Machine 
Edition Start menu group. All of your existing projects, settings, and authorizations 
are preserved following an uninstall operation.

T o  i n s t a l l  L o g i c  D e v e l o pe r  -  P LC  
1. Insert the Machine Edition CD into your CD-ROM drive. 

By default, the setup program automatically starts. If the setup program does not 
automatically start, run Setup.exe in the root directory of the CD.

2. Click Install to start the install process.

3. Follow the instructions as they appear on the screen.

Note: See the IPI Release Notes for information on troubleshooting installation 
problems.
4 Proficy™ Logic Developer - PLC 5.50 GFK-1918G
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W e l c o m e
Product Authorization
P R O D U C T  A U T H O R I Z A T I O N
Before you can start developing projects in with Logic Developer - PLC, you must 
authorize the software. If you do not do so, you will have unrestricted use of the 
software’s features only for a short trial period. The authorization process takes 
only a few moments and enables you to take advantage of any product support for 
which you qualify.

There are two types of authorization available: software key authorization and 
hardware key authorization. Machine Edition products can use a mixture of 
authorization types on a single computer.

To see which products you are currently authorized for, on the Machine Edition 
Help menu, point to Product Authorization and choose Authorize Software. This 
displays the Product Authorization dialog box. If you have a hardware key plugged 
in a USB port, you can select the Show Hardware Keys check box to view the 
authorizations provided by that key.

H a r d w a r e  K e y  A u t h o r i z a t i o n

Hardware key authorization requires a special USB hardware key. This key 
contains settings that allow use of specific Machine Edition products. Hardware 
keys can be used to authorize Machine Edition development and runtime software.

Hardware key authorization is available only for Windows 2000 or Windows XP 
and requires a free USB port on your computer.

T o  a u t h o r i z e  M a c h i n e  E d i t i o n  p r odu c t s  w i t h  a  H a r dw a r e  k e y
1. Locate a free USB port on your computer.

Typically, the USB port is located on the front or back of your tower case, or in the 
side of a laptop computer. In some cases, a USB port can be found on your 
computer’s monitor.

2. Plug the hardware key into the USB port.

The first time you plug the key into a USB port, a progress dialog box indicates that 
Windows has detected new hardware and is updating its system settings. After the 
dialog box disappears, the settings stored in the hardware key are active and you 
can use the Machine Edition products that it authorizes.

You must leave the hardware key in the port while using Machine Edition. If you 
remove the key from the port, authorization for those products vanishes, though 
you can still use products previously authorized by means of a software key.
GFK-1918G Proficy™ Logic Developer - PLC 5.50 5
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Product Authorization1
To move authorization to another computer, simply remove the hardware key from 
the source computer and plug it into a USB port on the destination computer.

S o f t w a r e  K e y

When authorizing Machine Edition products with a software key, you need to 
contact us by telephone, fax, or e-mail. If you want to authorize your software by 
telephone, note that authorization personnel are available only during regular 
business hours (between 6 a.m. and 6 p.m. MST).

Software key authorization is specific to a single computer. If you want to work 
with Machine Edition on a different computer, you must move the authorization to 
that second computer (see page 7).

T o  a u t h o r i z e  a  c o p y  o f  M a c h i n e  E d i t i o n  w i t h  a  s o f tw a r e  k e y
1. Have your serial numbers ready. 

The serial numbers can be found on the License Key sheet that came with your 
product. 

2. Run the Product Authorization program from the Start menu > Programs > GE Fanuc > Proficy Machine 
Edition > Product Authorization. 

The Product Authorization dialog box appears.

3. Click Add.

4. In the dialog box that appears, select the medium with which you are authorizing: Internet, Phone/Fax/E-mail, 
or Floppy Disk Transfer. Click Next.

If you choose the Internet option, follow the instructions on the web site. 

If you choose the Phone/Fax/E-mail option, proceed to step 5. 

If you choose the Floppy Disk Transfer option, ensure you have an authorization 
disk before proceeding. 

5. Fill in the fields in the dialog box. 
Fields that are identified with an asterisk (*) must be filled in. 

6. If authorizing by:

■ Phone, click Phone/Fax and call the number on the screen to receive one or 
more new key codes.

■ Fax, click Phone/Fax. In the dialog box that appears, click Print FAX. Fax the 
Product Authorization Request to us, using our fax number on the printout. We 
will reply by fax with your new key code(s).

■ E-mail, click Send E-mail. In the dialog box that appears, click Authorize to e-
mail us. We will reply by e-mail with your new key code(s).
6 Proficy™ Logic Developer - PLC 5.50 GFK-1918G
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Product Authorization
Product Authorization is complete after you enter the new key code and it has 
been accepted. Depending on the products you have purchased, you may need to 
run the Product Authorization program a number of times.

T o  m o v e  t h e  a u t h o r i z a t i o n  t o  a n o t h e r  c o m p u t e r
You can run the software only on the computer that has Product Authorization. To 
develop your projects on a different computer, you need to complete the following 
steps to move the authorization from one computer to another. 

1. Install Logic Developer - PLC on the computer that the authorization will be moved to. Run the Product Authorization 
program: Start menu > Programs > GE Fanuc > Proficy Machine Edition > Product Authorization.
The Product Authorization dialog box appears.

2. Click Move, and then click OK.

There is a Target Site Code on the top right hand side of the screen. Write down 
this site code carefully. It must be correct for the move to work. You need the Target 
Site Code when you move the authorized software from the source computer. 

3. Click Authorize by disk. 
At this point, you need to go to the source computer that has the authorized 
software, and move the authorization to a disk. 

4. From the source computer, run the Product Authorization program.

5. Click Move and then click OK. Enter the Target Site Code that you wrote down from Step 2 and click Next. Verify 
that the site code is correct and click OK.

6. Insert a blank formatted floppy disk into the floppy drive and click Next. 
The authorization code will be moved to the disk and a dialog box should appear 
telling you it was successful. 

7. Click OK.

8. Go back to the computer to which you are moving the authorization and insert the floppy disk. 
The screen that is asking for an authorization disk should be displayed.

9. Click Next.

10. Click Finish. 
A screen should appear telling you the move was successful. 

11. Click OK.

The authorization has now been moved to the new computer.
GFK-1918G Proficy™ Logic Developer - PLC 5.50 7
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Technical Support1
T E C H N I C A L  S U P P O R T
Support is available to registered users at no charge for 90 days after purchase. A 
support agreement can be purchased from your local GE Fanuc distributor if 
extended support is required.

If problems arise that cannot be solved by using the information in your product 
manual, online Help system, or the Proficy™ GlobalCare knowledge base, contact 
us by telephone, fax, or e-mail.

When contacting us, call from a telephone near your computer and have your 
Machine Edition software running. Have the following information handy to help 
us assist you as quickly as possible:

■ The serial number from your installation License Key sheet, and the Product 
name and version number from the Help>About dialog box.

■ The brand and model of any hardware in your system.

■ Operating system and version number.

■ The steps you performed prior to the problem occurring.
8 Proficy™ Logic Developer - PLC 5.50 GFK-1918G
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Technical Support
N o r t h  A m e r i c a
Support Hotline: 1-800-GEFANUC (1-800-433-2682) Fax: (780) 420-2049
Internet: http://www.globalcare.gefanuc.com E-mail: support@gefanuc.com
Comments about our manuals and help: doc@gefanuc.com
Mailing Address: GE Fanuc 

2700 Oxford Tower, 10235 - 101 St.
Edmonton, AB, Canada, T5J 3G1

S o u t h  A m e r i c a
Telephone: +58 (261) 760 2862 Fax: +58 (261) 765 0909
Internet: http://www.gefanuc.com (visit our Portuguese web site at www.gefanuc.com.br) 
E-mail: luis.wilhelm@gefanuc.com
Mailing Address: GE Fanuc Automation Latin America

Calle 120 con Av. 17, Los Haticos -GE Turbimeca
Maracaibo, Venezuela

E u r o p e ,  M i d d l e  E a s t ,  a n d  A s i a
Telephone: 00 800 1 GE FANUC Fax: 

81-3-5405-7555 (Japan) 81-3-5405-7550 (Japan)
0086-21-32224555 x200 (China) 0086-21-62793066 (China)

Internet: For up-to-date contact information, visit www.gefanuc-europe.com and click on “Offices and Services”.
For up-to-date technical information visit www.gefanuc.com/support.

E-mail: support.emea@gefanuc.com 
GFK-1918G Proficy™ Logic Developer - PLC 5.50 9
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P r o f i c y  M a c h i n e  E d i t i o n
2 Proficy Machine Edition
Proficy Machine Edition offers you a complete solution for the development of 
automation applications, in one package. Machine Edition features an integrated 
development environment and tools that enable you to spend more time building 
applications and less time learning the software. All Machine Edition products are 
fully integrated into the environment and interact with each other. 

■ They share the same set of tools providing a consistent interface throughout the 
development process.

■ They feature full drag-and-drop capabilities between tools and editors.

■ They feature a true scalable solution. You have the choice of what type of PLC 
your projects run on. 

The following illustrates a Machine Edition project:
GFK-1918G Proficy Logic Developer - PLC 5.50 11
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2

Navigator

Inspector

Companion

Data Watch

Toolchest

InfoViewer

Help Index

Feedback Zone
12 Proficy Logic Developer - PLC 5.50 GFK-1918G
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P r o f i c y  M a c h i n e  E d i t i o n
Quick Start
Q U I C K  S T A R T
Machine Edition makes it easy to get started developing a project.

To  s t a r t  Ma c h i n e  E d i t i o n
1. Click , point to Programs, point to GE Fanuc, point to Proficy Machine Edition, and then choose 

Proficy Machine Edition.

After Machine Edition initializes, the Environment Themes dialog box appears.

Note: The Environment Themes dialog box appears automatically the first time you 
start Machine Edition. To change the theme later, choose Apply Theme from the 
Windows menu.

2. Choose the Logic Developer - PLC theme.

3. Click OK.

When you open a project, the appearance of your Machine Edition screen matches 
the preview displayed in the Environment Themes dialog box.
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P r o f i c y  M a c h i n e  E d i t i o n

Quick Start2
The Machine Edition dialog box appears.

4. Select the appropriate option to open a project. The Open an existing project option is selected by default.

Notes:

■ If you select either the Empty project option or the Machine Edition template 
option, the New Project dialog box appears and you can continue creating a 
new project (see page 15).

■ If you select the Open an existing project option, you can also select either the 
Recent Projects option or the All Projects option. The Recent Projects option is 
selected by default.

5. If you selected the Open an existing project option, select from the list the project that you want to open.

6. If you want, select the Don’t show this dialog box on startup option.

7. Click OK.

Your project opens in the Machine Edition environment that you specified in the 
Environment Themes dialog box.

Select this option if you
want to create a new project
from scratch.

Select this option if you
want to use a Machine Edition
template to create your project.

Select this option if you want
to choose an existing project.

Select this option to display only
the projects that have been
used recently. Select this option to display

all projects stored on your computer.
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P r o f i c y  M a c h i n e  E d i t i o n
Projects
P R O J E C T S
You can create and edit Machine Edition projects by using products such as View, 
Logic Developer - PC, Motion, Logic Developer - State, and Logic Developer - 
PLC. These products share Machine Edition tools to provide a high level of 
integration between the various parts of your project.

You can import folders created with Logicmaster, CimplicityControl, or VersaPro.

With Logic Developer - PLC, you can build multiple projects to suit your specific 
requirements. 

T o  c r ea t e  a  n ew  p r o j e c t  u s i n g  a  t e m p l a t e
Before creating a project, there are some things you should know:
■ The primary components your project will contain. 

■ The GE Fanuc controller your project will run on.

1. From the File menu, choose New Project, or click  on the File toolbar.

The New Project dialog box appears.

2. Choose a Project Template that suits your needs. 

3. Enter a descriptive Project Name.

4. Click OK.

Your project opens in the Machine Edition environment.

Enter the name of 
your project in the 
Project Name box.

Choose your project 
template from the 
Project Template 
list. You can set the selected 

project template as the 
default template by 
clicking the Set as default 
button.

A sample description of the 
project appears on the 
screen. 
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P r o f i c y  M a c h i n e  E d i t i o n

Projects2
T o  o p e n  a n  e x i s t i n g  p r o j e c t  f o r  e d i t i n g
1. Open the  Navigator and select the Manager tab. 

A list of projects appears. 

2. Do one of the following: 

■ Right-click a  project and choose Open. 
- or -

■ Double-click a project.

Your project loads and is ready for editing.

To  i m po r t  a  f o l d e r
1. Open the Navigator and select the Project tab. 

2. Select the target that you want to import the folder into.

3. Right-click the target, point to Import, and choose the folder type. 

4. In the dialog box that appears, navigate to and double-click the folder you want to import. 

Want to know more? In the online help index, look up “Projects”.

Want to know more? In the online help index, look up “importing CimplicityControl folder”, 
“importing Logicmaster folder”, or “importing VersaPro folder”.

Navigator: Manager tab
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P r o f i c y  M a c h i n e  E d i t i o n
Tools
T O O L S
Project development is supported by the Machine Edition tools. Each tool is 
opened by means of a button on the Tools toolbar.

A description of each tool’s function is provided below.

The Navigator is a docking tool window containing a set of tabs. Each tab displays 
information about your development system in a hierarchical tree structure similar 
to Windows Explorer. The available tabs depend on which Machine Edition 
products you have installed and what kind of work you are developing or 
managing. The Project tab shows the overall organization of your application.

The Feedback Zone window is a docking window used to display several types of 
output information generated by Machine Edition components. This interactive 
window uses category tabs to organize the output generated from the Machine 
Edition products you have installed. 

The Inspector lists the properties and current settings for a selected object or 
element. You can edit these properties directly in the Inspector. When you select 
several objects, the Inspector window lists the properties common to all of them. 
The Inspector window provides a simple method of viewing and setting properties 
for all Machine Edition objects.

The Data Watch tool is a run-time debugging tool that enables you to monitor and 
edit the values of variables. This tool is useful while working online to a target. 
With the Data Watch tool, you can monitor individual variables or user-defined 
lists of variables. Data Watch lists can be imported, exported, or saved with a 
project.

The Toolchest is a powerful storehouse of objects you can add to your project. You 
can drag most items directly from the Toolchest into Machine Edition editors. You 
can choose from predefined objects or create your own reusable fxClasses. The 
Toolchest adds true object-oriented capability to Machine Edition.

Navigator

Feedback Zone

Data Watch
Toolchest 

Companion

Infoviewer

Inspector

 N a v i g a t o r

 F e e d b a c k  Z on e

 I n sp e c t o r

 D a t a  W a t c h

 T oo l c h e s t
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P r o f i c y  M a c h i n e  E d i t i o n

Tools2
The Companion provides useful tips and information while you work. While the 
Companion is open, it tracks your moves and displays help on whatever item is 
currently selected in the Machine Edition environment. It is context-sensitive and 
displays a description of whatever you click on the Machine Edition screen.

The InfoViewer is an embedded Web browser used mainly to display the following

■ Machine Edition help.

■ Machine Edition reports.

■ The documentation associated with a project or target.

If you are familiar with Internet Explorer or Netscape Navigator, then you are 
already familiar with the basic InfoViewer interface. Like the Companion, the 
InfoViewer is context-sensitive. Press F1 to get help on any item you select in the 
Machine Edition environment. 

A table of contents is found in the InfoView tab of the Navigator. 

U s i n g  d o c k i n g  m a r k e r s

If the Show Docking Markers option is enabled, you can use docking markers to 
help dock a tool window to a desired location.

As you drag a dockable window, a series of docking markers appear, indicating 
valid docking locations. Docking markers appear as a series of blue arrows. Move 
the mouse over a docking marker to preview how the window would be docked 
when using that marker. Release the mouse button while hovering over a marker to 
use that location.

Want to know more? In the online help index, look up “Tools: an Overview”.

These markers dock tools to the edge of an existing tool or to the 
Machine Edition Environment window.

This marker “stacks” the tool overtop an existing tool window, 
forming a series of tab-docked windows. You can then switch 
between tab-docked tools by clicking the tabs that appear at the 
bottom of the tab-docked windows.

 I n f o V i e w e r

 C om p a n i o n
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P r o f i c y  M a c h i n e  E d i t i o n
Variables
V A R I A B L E S
A variable is a named storage space for data. That is, the variable name represents 
a memory location in the target PLC. The way in which the variable represents a 
memory location is determined by the value of the variable’s Ref Address property. 
A variable's Ref Address property can be set to any of the following:

■ A reference address, for example, %R00001. This is the GE Fanuc PLC memory 
location that contains the variable's value. This can be an I/O register or an 
internal memory register on the PLC. 

■ A blank. On a PACSystems, if you leave a variable's Ref Address property blank, 
the variable is a symbolic variable. Machine Edition handles the mapping for 
you in a special portion of PACSystems user memory space. On Series 90 and 
VersaMax PLCs, you cannot leave the Ref Address property blank.

■ An I/O variable address, for example %IX0.6.0.1. (PACSystems only.) This 
represents the PACSystems Hardware Configuration terminal that contains an 
I/O variable's value. For example, this can be a physical discrete or analog I/O 
point on a module or Genius device, a discrete or analog status returned by the 
module, or global data.

■ A name. This makes the current variable an alias variable of the name, that is, a 
variable that points to the same memory location as the name. The following 
names may be valid:
✐ The name of a parameterized LD block parameter (provided the alias 

variable is local to the same block)
✐ The name and index of an array element, for example, 

MyComplexArray[255,3]
✐ The name of a structure element, for example, MyStructure.MyElement
✐ The name of another variable that is not used as an alias variable. 

Want to know more? In the online help index, look up “Reference Address (GE Fanuc PLCs)”, 
“Symbolic Variables”, “I/O Variables”, and ”Alias Variables”.

Navigator: Variables tab. This tab 
displays all the variables used in a 

project.
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P r o f i c y  M a c h i n e  E d i t i o n

Variables2
Arrays and compound structure variables are supported by Machine Edition. 
Variable definitions can be imported from and exported to a variety of file types. 
You can edit your variables in a spreadsheet and then import them. Variables used 
on PACSystems targets must be externally published in order to be viewed in 
Proficy View. 

The Ref Address and other properties of a variable, such as Data Type, are 
configured in the Inspector. The following is an illustration of the Inspector 
displaying a typical set of variable properties.

Want to know more? In the online help index, look up “Arrays in GE Fanuc PLC targets”, 
“Structure Data Types”, “Importing variables from a file”, and ”Publishing PACSystems 
variables”.
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P r o f i c y  M a c h i n e  E d i t i o n
Variables
To  c r ea t e  a  va r i a b l e
1. In the  Variables tab of the  Navigator, right-click   Variable List, point to New Variable and then 

choose the data type of the variable.

The New Variable dialog box appears.

2. Type a name for the variable.

Variable names can range from 1 through 32 characters, begin with a letter or the 
$ character, contain upper or lower case letters, use numbers between zero and 
nine, and use the underscore character (“_”).

3. Select the target the variable will be used in.

4. If the new variable is an array, select the Array check box and enter the size(s).

5. Click OK.

The new variable appears in the list in the Variables tab.

T o  m a p  a  v a r i a b l e  t o  P LC  m e m o r y  o r  a l i a s  a  v a r i a b l e
There are two ways to map a variable to PLC memory or alias any variable.

First method:

1. In the Variables tab of the Navigator, right-click a variable and choose Properties. 

The Inspector displays the properties of the variable. 

2. In the Ref Address field, enter a reference address to map the variable or enter the name of another existing 
variable, a parameterized LD block parameter, an array element, or a structure element to alias the variable. 
■ Spell out the exact reference address, for example, %R00123 or 123R (in either 

case this maps the variable to %R00123), or enter only the memory area, for 
example %R. This maps the variable to the next available address in that 
memory area. For example, if %R00122 is the last address used by a 16-bit 
variable, entering %R maps the variable to %R00123.

■ Spell out the name of another variable, or of a parameterized LD block 
parameter, for example, MyVarWithALongName, or Abc. Or provide the array’s 
name and the element’s number, for example, MyArray[5]. Or provide the 
structure element’s name, for example, MyStructure.MyElement.

New Variable menu
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P r o f i c y  M a c h i n e  E d i t i o n

Variables2
Notes (PACSystems only)

■ If you leave the Ref Address property of a variable blank, the variable is a 
symbolic variable.

■ You can enter an I/O variable address to make the variable an I/O variable, but 
it is easier to map an I/O variable in the Terminals tab of a module. See “I/O 
variables”, on page 60.

Second method:

1. In the Variables tab of the Navigator, right-click a variable and choose Properties. 

The Inspector displays the properties of the variable. 

2. Click the Ref Address field and then click the  button. 

The Reference Address Wizard appears. 

3. Do one of the following:
To map a variable to PLC memory

a. From the Memory Area list, choose a region of PLC memory.

b. In the Index box, enter an index from the beginning of the region.

c. Select a bit reference. 

The Bit Reference box is available only if you're mapping a BOOL variable to 
16-bit memory area on a PACSystems.

d. Click OK.
Your variable is mapped to the reference address.

- or -
To alias a variable

a. In the Variable Aliasing Filters section, select the appropriate check boxes for the filters you want to use.

b. In the Alias variable to box, select what you want to alias the variable to.

c. Click OK. 

Want to know more? In the online help index, look up “Bit references in non-BOOL 
variables”.

When mapping, select a 
region of memory.

When mapping, a 
BOOL variable in 16-
bit memory, select a 
bit reference.

When mapping, select an 
index.

When aliasing, select a 
variable, LD block 
parameter, or element.

When aliasing, select a 
filter.
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P r o f i c y  M a c h i n e  E d i t i o n
Options
O P T I O N S
The Options tab of the Navigator contains option and preference settings. Options 
are organized into folders and pages. Click  or  to expand or collapse folders. 
Examples:

 Editors >  Ladder >  View > Coil Justification: The default column in 
which coils are placed; also the column where the right power rail resides. The 
default is 10.

 Machine Edition >  Preferences > Visual Style: The visual style used for the 
Machine Edition environment, including the appearance of toolbars, tool 
windows, and menus. You can choose from several visual styles based on different 
versions of Microsoft products and the Windows operating system: Classic (based 
on Windows 2000), XP, 2003, and 2005.

 PLC >  General > Duplicate Addresses: Indicates whether to prevent, warn 
about, or ignore mapping two variables of the same data size (1, 8, 16, or 32 bits) 
and length (array size) to the same reference address.

 PLC >  Hardware Configuration > New Reference Assignment: The way in 
which default reference addresses are assigned when modules are added to the 
Hardware Configuration.

T o  s e t  op t i o n s  a n d  p r e f e r en c e s
1. In the  Options tab of the Navigator, expand an options  folder and right-click a  page within the 

folder to display the options in the Inspector.

2. In the  Inspector, edit the option’s settings as needed.

TIP: When you click an option, the Companion automatically displays help on that 
option. If the Companion is not already open, press SHIFT + F11 to open it.

T o  r e s e t  a n  en t i r e  p a ge  o f  op t i o n s  t o  t h e i r  d e f a u l t  s e t t i n g s :
1. In the  Options tab of the Navigator, expand an options  folder.

2. Right-click one of the  options pages, and then choose Reset.

TIP: To reset only one option, look up its default value in the Companion and set 
the option to that value.

Navigator: Options tab
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Machine Edition Help2
M A C H I N E  E D I T I O N  H E L P
Machine Edition includes a comprehensive online help system that enables you to 
access specific help topics while working with Machine Edition.

Use the InfoViewer or Companion to access help.

C o m p a n i o n  H e l p

The Companion is a Machine Edition help system that provides useful tips and 
information while you work. While the Companion is open, it displays help on 
whatever item is currently selected in the Machine Edition environment.

T o  u s e  C om p a n i o n  h e l p
1. Ensure that the Companion is open. To open it, press Shift+F11.

2. Click any item in Machine Edition, outside the Companion.

A description of the item you clicked appears in the Companion. 

I n f o V i e w e r  H e l p  

The InfoViewer, another Machine Edition help system, provides detailed 
information. The InfoViewer has its own toolbar for navigating the help system, a 
Table of Contents (in the InfoView tab of the Navigator), an index, and a full-text 
search engine. InfoViewer help is context-sensitive. Click an item on the screen 
and press F1 to display the appropriate topic in the InfoViewer.
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P r o f i c y  M a c h i n e  E d i t i o n
Machine Edition Help
T o  u s e  t h e  He l p  i n d e x  
1. From the Help menu, choose Index. 

The Index dialog box appears. 

2. Enter a keyword in the top text box or select one in the middle text box. 

3. Click List Topics.

A list of topics appears in the bottom text box. The topics are sorted by their rating 
or likelihood of containing the correct information. 

4. In the bottom text box, select a topic to display.

5. Click Display.

The selected Help topic is displayed in the InfoViewer. 

TIP: To narrow a search, click the Location heading. The list of topics will be sorted 
by location and then by rating.
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Machine Edition Help2
T o  u s e  t h e  f u l l - t e x t  s e a r c h
You can use the standard HTML Help Viewer to perform a full-text search of the 
Help. Advanced boolean search expressions can be applied.

1. From the Help menu, choose Search.

The Machine Edition Help Search dialog box appears.

2. Enter a search word or phrase in the top text box. SURROUND A PHRASE WITH QUOTATION MARKS.

3. Click to perform a boolean search; that is, use AND, OR, NEAR, or NOT to create a boolean search expression.

4. Click List Topics.

A list of topics appears in the Select topic box. The topics are sorted by their rating 
or likelihood of containing the search term, terms, or phrase. 

5. In the Select topic box, select a topic to display.

6. Click Display.

The selected Help topic is displayed in the Help Viewer. 

7. (Optional.) Click the InfoViewer button to display the current topic in the InfoViewer.
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Machine Edition Help
Tips: 

■ To narrow the search results, click the Location heading. The listed topics are 
sorted by location and then by rating.

■ When using the HTML Help Viewer window, you may get better results if you 
select the “Search titles only” check box and/or clear the “Match similar words” 
check box.

T o  b oo k m a r k  f a v o r i t e  t op i c s
1. After using the HTML Viewer to perform a full-text search, select a topic you want to add to your list of favorite topics 

and then click the Favorites tab.

The selected topic title is displayed in the Current topic text box.

2. Click Add.

The topic is added to the Topics list.

3. (Optional.) Click the InfoViewer button to display the current topic in the infoViewer.

4. To display a favorite topic in the Help Viewer, select it and click Display.

5. To remove a topic from the Favorites list, select it and click Remove.
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Machine Edition Help2
T o  l o ok  u p  t o p i c s  i n  t h e  H e l p  Ta b l e  o f  Co n t e n t s
1. Click the  InfoView tab of the Navigator.

A table of contents for the entire help system appears. 

2. Expand  Libraries and Books to locate a topic of interest

3. Double-click a  topic. 

The topic is displayed in the InfoViewer.

Navigator: InfoView Tab
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3 GE Fanuc Targets
A  target represents a run-time destination of the program or programs you 
develop with Logic Developer - PLC. Each target contains all of the components 
associated with that target. Logic Developer - PLC supports the following GE Fanuc 
families of PACSystems controllers, Series 90 PLCs, and VersaMax PLCs:

■ PACSystems RX7i

■ PACSystems RX3i

■ Series 90-70 PLC

■ Series 90-30 PLC

■ VersaMax PLC

■ VersaMax Nano/Micro PLC

■ Series 90 Micro PLC

and the following GE Fanuc remote I/O interface targets: 

■ GE Fanuc Series 90-30 Ethernet Network Interface Unit

■ GE Fanuc Series 90-70 Genius Remote I/O Scanner

■ GE Fanuc VersaMax Ethernet

■ GE Fanuc VersaMax Genius

■ GE Fanuc VersaMax Profibus

Navigator: New PACSystems Project
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G E  F a n u c  Ta r g e t s

Adding, Configuring and Converting Targets3
A D D I N G ,  C O N F I G U R I N G  A N D  C O N V E R T I N G  
T A R G E T S

A d d i n g  T a r g e t s

Typically a target is present in a project when you use a template to create the 
project (see page 15). A project can contain multiple targets. Before grouping 
targets into a project or isolating each target in its own project, consider the 
following:

■ How large are the targets? For example, a target that contains 200,000 variables 
should probably be by itself in a project. 

■ Are the targets related? For example, a PACSystems with a relatively small 
program is connected to twenty GE Fanuc Remote I/Os (RIOs). Size is not an 
issue because RIO targets use little memory in a project. Grouping all the 
targets into one project is appealing because it makes navigation much easier 
from one target to another than if the PACSystems and RIOs are isolated in 21 
separate projects. For another example, if you have various targets that do not 
communicate with one another or do not serve a common purpose, there may 
be little value in grouping them in one project.

One target is required for each PLC or remote I/O adapter your project accesses, 
except when you are using CPU redundancy. In this case, one target contains a 
Primary Hardware Configuration and a Secondary Hardware Configuration, which 
correspond to the primary PLC and the redundancy PLC, respectively. For more 
information, see page 62.

Existing targets can be converted from one PLC family to another. For more 
information, see page 32.

To  a dd  a  t a r g e t  t o  a  p r o j e c t
1. In the  Project tab of the  Navigator, right-click the Project node and point to Add Target.

2. Point to GE Fanuc PLC or GE Fanuc Remote I/O and then respectively choose the GE Fanuc PLC family or the 
Remote I/O.

A new target appears in the Project tab of the Navigator. When expanded, the new 
target contains a default Hardware Configuration, logic blocks, and miscellaneous 
components.

Project right-click menu
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C o n f i g u r i n g  P L C  T a r g e t s  

The properties of a target specify the PLC family, the communication connections 
between your computer and the PLC, and various other settings. All properties are 
edited in the Inspector. The following table describes a PLC target’s properties: 

Other properties are available depending on the value of the Family property and 
the CPU model.

T o  c on f i g u r e  a  P L C  t a r g e t
1. In the Project tab of the Navigator, right-click a target and choose Properties.

The properties of the target appear in the Inspector. 

2. In the Inspector, configure the properties as needed.

Name Edit the name for your target in this field.

Type The type of target is set by default to GE Fanuc PLC. Here the 
expression “GE Fanuc PLC” includes PACSystems controllers.

Description Enter a description of your project in this field. The maximum 
number of characters is 255.

Documentation Address Enter the URL where your project documentation is stored.

Family By changing the PLC type in this field, you initiate a target 
conversion. Caution: Changes are irreversible.

PLC Target Name The name of the target as stored on the PLC.

Update Rate (ms) Set the rate at which the screen is updated while online to the 
target. 

Sweep Time (ms) The sweep time of the PLC when online. This value is also 
displayed on the status bar. (Read-only.)

PLC Status The online/offline, run/stop status of the PLC. (Read-only.)

Online Project Synchronization When Enabled, Machine Edition performs project 
synchronization checks with an online PLC.

Physical Port Choose the type of connection to the PLC (Ethernet, COM, or 
modem).

IP Address (Ethernet protocol only.) Set the IP address of the PLC. 

Additional Configuration Group of properties used for the detailed configuration of your 
communication connection. 

 Modem Communication Group of properties to configure the modem communications 
link between your computer and a remote GE Fanuc target.
GFK-1918G Proficy Logic Developer - PLC 5.50 31
sales@roc-electric.com   www.roc-electric.com



G E  F a n u c  Ta r g e t s

Adding, Configuring and Converting Targets3
C o n v e r t i n g  T a r g e t s

With Logic Developer - PLC, you can convert targets from one GE Fanuc PLC 
family type to another. For example, you can take the Hardware Configuration and 
logic written for a Series 90-70 PLC and convert them for use on a PACSystems 
RX7i. However, target conversions are irreversible; when logic blocks are deleted 
during a conversion, they cannot be restored. It is recommended that you make a 
backup of your project before converting a target. There may also be logic 
execution differences when converting an application from one GE Fanuc PLC 
family type to another, especially if a Series 90-70 is involved in the conversion. 
You must validate the application execution prior to deployment into a production 
environment.

T o  c o n ve r t  a  t a r ge t
1. In the Project tab of the Navigator, right-click a target and choose Properties.

The Inspector displays the target’s properties.

2. In the Inspector, click Family.

3. From the list, choose the new GE Fanuc PLC Family you want to convert the target to.
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There are two types of target conversions. 

A basic conversion does the following:

■ Strips all the configured modules from the original Hardware Configuration 
(HWC) and sets up the destination family’s default HWC, with a single power 
supply and a CPU.

■ Deletes or adds target components, and logic programs or blocks.

■ Updates the system variables, including the fault locating references if 
applicable.

An enhanced conversion does the following:

■ Replaces a power supply with the destination family’s default power supply.

■ Retains the settings of CPU parameters common to the original and destination 
CPUs when the settings are supported in the destination family; otherwise, 
replaces them with the default settings.

■ Retains all the original modules that are supported by the destination family. 
Retains all the module parameter settings that are supported by the destination 
family; otherwise, the default settings are used.

■ Ethernet module settings of non-supported Ethernet modules are used to 
configure the destination's Ethernet daughterboard or default Ethernet modules.

■ Converts unsupported expansion racks to the nearest equivalents.

■ Deletes or adds target components, and logic programs or blocks.

■ Updates the system variables, including the fault locating references if 
applicable.

■ Displays a conversion report in the InfoViewer.

Caution: The capabilities of a destination target may be different from those of the 
original target. Carefully examine the conversion report when it is available. 
Validate the project and test it thoroughly before deploying it in production.

Note: GE Fanuc PLC hardware must be configured before it is operational. For 
detailed information on hardware configuration, see page 55.

Want to know more? In the online help index, look up “Target Conversions”.
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C O N F I G U R I N G  C O M M U N I C A T I O N  
For Logic Developer - PLC to communicate with a target PLC, a connection must 
be properly configured. The properties of a target are adjustable to accommodate 
your connection(s).

T o  c on f i g u r e  a n  E t h e r n e t ,  m od e m ,  o r  s e r i a l  c o n n e c t i o n  w i t h  a n y  G E  F an u c  P L C
1. In the  Project tab of the  Navigator, right-click a  target and choose Properties.

The Inspector displays the target’s properties. 

2. In the Inspector, set the Physical Port property to Ethernet or a COM port (or a modem if one is installed). 

3. If the Physical Port is Ethernet, enter the IP Address of the target PLC. 

4. Double-click Additional Configuration to access the detailed settings for your connection. 

Note: An IP address must be set in the PLC before an Ethernet connection can be 
established. 

T o  s e t  a  t e m p o r a ry  I P  a d d r e s s  f o r  a  P A C S y s t e m s  P LC  t a r ge t  o r  V e r sa Ma x  E t h e r n e t  N I U  t a r g e t
1. In the Utilities tab of the  Navigator, double-click Set Temporary IP Address.

Want to know more? In the online help index, look up “configuring communications with GE 
Fanuc PLC target”.
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The Set Temporary IP Address dialog box appears.

2. In the MAC Address field, specify the MAC address for the target.

3. In the IP Address to Set field, specify the temporary IP address you want to set on the target.

4. If required, select the Network Interface Selection check box and specify the network interface the target is located 
on.

5. Click the Set IP button.

The IP address of the specified PLC or device is temporarily set to the indicated 
address.

Warning: The IP address set by the Set Temporary IP Address utility is not retained 
through a power cycle. If you want to set a permanent IP address, you must 
download the Hardware Configuration to the PLC.
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36

3

T o  s e t  a  p e r m a n e n t  I P  a d d r e s s  f o r  a  P A C S y s t e m s
1. In the Project tab of the Navigator, right-click the target and choose Properties.

The  Inspector displays the target’s properties.

2. In the IP Address property, enter an IP address.

3. Expand the  Hardware Configuration and expand the  main rack.

4. Do one of the following: 

■ For a PACSystems RX7i, expand the  CPU and double-click the Ethernet 
subnode.
- or -

■ For a PACSystems RX3i, double-click every  IC695ETM001 Ethernet module 
and repeat step 5 for each one of them.

5. In the Settings tab that appears in the Parameter editor, set the IP Address, the 
Subnet Mask, and the Gateway IP Address.

6. Download the Hardware Configuration to the PACSystems RX7i.

T o  s e t  a n  I P  a d d r e s s  f o r  S e r i e s  9 0 - 7 0  P L C s
1. In the Project tab of the Navigator, expand the  Hardware Configuration. 

2. Expand the  main rack and double-click the slot where you want to add a communications module.

The Module Catalog appears.

3. Choose the Communications tab and select the communications module you want to add.

Select either IC697CMM741 or IC697CMM742.

Want to know more? In the online help index, look up “Configuring communications with GE 
Fanuc PLC target” and “Set Temporary IP Address utility”.
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4. Click OK.

The Parameter editor displays the configuration settings for the module.

5. In the Settings tab, double-click the IP Address parameter.

The IP Address dialog box appears.

6. Enter the IP Address and click OK.

7. Download the hardware configuration. For more information, see page 41.

T o  s e t  a n  I P  a d d r e s s  f o r  a  S e r i e s  9 0 - 3 0  C P U 3 6 4 ,  C P U 3 7 4 ,  N I U 0 0 4 ,  o r  a  V e r s a M a x  C P U E 0 5
Note: An Ethernet adapter is built into CPU364, CPU374, NIU004, and CPUE05. 
For other Series 90-30 CPUs, Ethernet connections are supported through an 
optional expansion slot on the rack.

1. Obtain an IP address, perhaps from your network administrator.

2. In the Project tab of the Navigator, expand the Hardware Configuration and expand the main rack. 

3. Right-click the slot containing the CPU364, CPU374, NIU004, or CPUE05 and choose Configure.

The Parameter editor appears.

4. In the Parameter editor, click the Ethernet tab. 

The Parameter editor displays the contents of the Ethernet tab.

5. Double- click the IP address parameter. 

The IP Address dialog box appears

6. Enter the IP address in the box and click OK.

7. Download the hardware configuration. For more information, see page 41.
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T o  s e t  a n  I P  a d d r e s s  f o r  o t h e r  S e r i e s  9 0 - 3 0  C P U s  ( n o t  CP U 3 6 4  o r  C P U 3 7 4 )
1. In the Project tab of the Navigator, expand the  Hardware Configuration. 

2. Right-click the slot containing an Ethernet Interface Module (IC693CMM321) and choose Configure.

The Parameter editor displays the configuration settings for the module. 

3. In the Settings tab, double-click the IP Address field.

The IP Address dialog box appears.

4. Enter the IP address and click OK.

5. Download the hardware configuration. For more information, see page 41.

T o  d ow n l o a d  a n  I P  a d d r e s s  v i a  a  P LC  s e r i a l  p o r t
1. Configure a CPU or Ethernet communications module with an IP address using Hardware Configuration.

2. Right-click the target and choose Properties.

The Inspector displays the target’s properties.

3. In the Physical Port property, select a serial connection.

4. Right-click the target and choose Go Online.

5. Right-click the target and choose Download to PLC.

The Download to PLC dialog box appears.

6. Select Hardware Configuration and click OK.

The IP address is assigned to the PLC. 

7. Right-click the target and choose Go Offline.

8. Right-click the target and choose Properties.

9. In the Physical Port property, select Ethernet.

The next time you go online, Machine Edition will use an Ethernet connection with 
the specified IP address.
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I N T E R A C T I N G  W I T H  A  P L C
Communicating with a PACSystems, Series 90, or VersaMax is necessary to 
perform such operations as storing and loading programs or monitoring data values 
and PLC status information. You can connect to a PLC from Logic Developer - PLC 
over a serial, Ethernet, or modem connection, depending on the PLC’s capabilities. 

All interactions with a target are available from the target’s right-click menu. 

V a l i d a t i n g  a  T a r g e t  

Validating your target detects syntax and configuration errors on the target. Error 
messages are generated for each error and displayed in the Feedback Zone. A 
target containing errors cannot be downloaded. A target is automatically validated 
before a download operation. 

T o  v a l i d a t e  a  t a r ge t
• In the Project tab of the Navigator, right-click a  target and choose Validate. 

Logic Developer - PLC checks all items under the target for syntax errors. Any 
errors detected are noted in the Build tab of the Feedback Zone.

Tip: Double-click an error message to locate the noted error in your project. The 
appropriate editor or tool opens automatically with the item in question selected. 
Press the F4 key to locate the next error or warning in your project. Tips showing 
you how to proceed are displayed in the Companion. To open the Companion, 
press SHIFT + F11.

O f f l i n e ,  O n l i n e :  m o n i t o r  m o d e ,  p r o g r a m m e r  m o d e

When offline from a PACSystems, Series 90, or VersaMax, there is no ongoing 
communication between the PLC and your development computer. A physical 
communication link is not required as long as you only edit logic; it is required 
only when you want to communicate with the PLC. 

The only PLC operations you can perform while offline are to go online or to set up 
the temporary IP address (see page 34).

When online with a target PLC, a communication link exists and is active and you 
have an ongoing real-time communication with the PLC. 

When online in monitor mode, you can monitor the PLC while it is executing. You 
cannot edit logic on your computer except State Logic. You cannot change any 
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values on the PLC. Depending on your level access on the PLC and your Change 
Management permission levels, you can upload from the PLC. 

When online in programmer mode, you can make changes on your computer and 
the PLC and can monitor the PLC while it is executing. You can edit any type of 
PLC logic on your computer. Depending on your level access on the PLC and your 
Change Management permission levels, you can upload from the PLC, control the 
PLC while it is executing, and change values on the PLC, including downloading 
to the PLC. You can edit LD logic while online; you are prompted to download 
your word-for-word changes. For more information on word-for-word changes, see 
page 91.

When online in either mode, if the project stored on the PLC is equal to the current 
project in Logic Developer - PLC, the LD editor displays a graphical representation 
of LD logic as it executes.

T o  g o  o n l i n e  t o  a  G E  F a n u c  P L C  
1. In the Project tab of the  Navigator, ensure that all the  target PLCs are offline. 

You can be online to only one target at a time. When a target is offline, its icon is 
grey.

2. If the name of the target you want to go online to does not appear in bold characters, right-click the target and 
choose Set as Active Target.
Bold characters indicate that this is the active target.

3. Do one of the following: 

■ Right-click the active target and choose Go Online.
- or -

■ Click the thunderbolt on the Online toolbar: 

Logic Developer - PLC connects your project to the GE Fanuc PLC. The online 
status is indicated by the target icon in the Project tab and on the status bar. 

Note: When online to a GE Fanuc PLC, the target icon in the Project tab of the 
Navigator appears as  (equal),  (not equal), or  (stop faulted). 

Want to know more? In the online help index, look up “Offline (Logic Developer - PLC)”.
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T o  c h a n g e  t h e  on l i n e  mo d e
• In the Project tab of the  Navigator, right-click the  target PLC, point to Online Commands, and 

choose Set Programmer Mode or Set Monitor Mode. 

T o  g o  o f f l i n e  f r om  a  GE  F an u c  P LC  
• Do one of the following:

■ In the Project tab of the  Navigator, right-click a   target PLC and 
choose Go Offline.
- or -

■ Click the thunderbolt on the Online toolbar: 

Logic Developer - PLC goes offline. 

U p l o a d / D o w n l o a d

The download process builds and validates all run-time files necessary for a target 
to perform its role in a completed project. The compiled project is then transferred 
to the target hardware over the communication connection previously configured. 
For more information, see page 34.

The upload process acquires a project from the active GE Fanuc PLC target and 
transfers it to Logic Developer - PLC for editing.

T o  d ow n l o a d  t o  a  G E  F a n u c  P L C
1. Ensure you are online in programmer mode to the target PLC.

2. In the Project tab of the Navigator, right-click the  target to which you want to download files and 
choose Download to PLC.

The Download to PLC dialog box appears.

Want to know more? In the online help index, look up “going online to GE Fanuc PLCs”, 
“setting online programmer mode”, “setting online monitor mode”, and “going offline from GE 
Fanuc PLCs”.
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Note: If the PLC is running, you can download only logic that is not equal to the 
PLC’s current logic and the Download to PLC dialog box does not appear. On a 
PACSystems, some source files that do not affect equality are also downloaded.

3. Choose the items you want to download and click OK. 

Note: Only one project can be downloaded to a target at a time. If you download 
to a target PLC that already has a project on it, the existing project is overwritten.

For each target that you download, Machine Edition performs a validation. Any 
errors that occur are displayed in the Build tab of the Feedback Zone. If there 
are no errors, Machine Edition builds and sends all the necessary run-time files to 
the PLC. 

T o  up l o ad  f i l e s  f r om  a  GE  F anu c  P LC
1. Ensure you are online to the target PLC.

2. In the  Project tab of the  Navigator, right-click the  target PLC from which you want to upload 
information and choose Upload from PLC.

The Upload from PLC dialog box appears.

3. Choose the item(s) you want to upload and click OK.

The selected items are uploaded to Logic Developer - PLC. If you already had a 
version of the PLC’s project open, the uploaded project merges with the existing 
project. Because variable names are not stored on non-PACSystems GE Fanuc 
PLCs, if you upload to an empty target, all variables are assigned default names. 
For example, %R00001 is named R00001. 

Want to know more? In the online help index, look up “downloading to GE Fanuc PLCs”.

Want to know more? In the online help index, look up “uploading from GE Fanuc PLCs”.
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R u n / S t o p

When you are online in programmer mode, you can set a target GE Fanuc PLC to 
Run or Stop mode. In Stop mode, you can choose to enable or disable the outputs.

T o  s t a r t  a  G E  F a n u c  P L C
• Do one of the following:

■ In the Project tab of the Navigator, right-click a  target, point to 
Online Commands, and then choose Start PLC.
- or -

■ Click  on the Online toolbar: 

The target PLC begins executing its program.

Note: If you are starting a PACSystems or Series 90-70 PLC, you can choose to 
have outputs enabled or disabled.

T o  s t o p  a  G E  F a n u c  P L C
1. Do one of the following:

■ In the Project tab of the Navigator, right-click a  target, point to 
Online Commands, and choose Stop PLC.
- or -

■ Click  on the Online toolbar: 
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The Stop PLC dialog box appears, prompting you to enable or disable the PLC’s 
outputs.

2. Select an option.

3. Click OK.

The target PLC stops executing its program. 

F a u l t  T a b l e s

The PLC and I/O Fault Tables display fault information logged by the CPU or 
modules in the PLC. This information is used to determine if there are problems 
with the PLC hardware or software running in the PLC’s CPU. 

T o  v i ew  t h e  f a u l t  t a b l e  r ep o r t s
• Do one of the following: 

■ In the Project tab of the  Navigator, double-click the  target you want a 
report on, or right-click it and choose Diagnostics.
- or -

■ In the status bar, at the bottom of the Machine Edition window, double-click the 
 target.

Note: To view the PLC and I/O fault tables, your computer must be online to the 
PLC. To clear faults, you must be in online programmer mode.

Want to know more? In the online help index, look up “starting GE Fanuc PLCs” and 
“stopping GE Fanuc PLCs”.
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The fault table appears in the InfoViewer window.

Want to know more? In the online help index, look up “fault” (in lower case), then select 
“Working with the Fault Tables”.

Print fault table by 
clicking here.

Indicates online 
status of PLC.

View the date and 
time of the faults.

Select the format of 
fault data.

Choose the type of 
fault information you 
require.

Sort fault 
information. 

Clear fault 
information by 
clicking here.

Double-click a row to 
view details of faults. 
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R e f e r e n c e  V i e w  T a b l e s

Reference View Tables (RVTs) are tables in which you can monitor reference data 
when you are online to a GE Fanuc PLC. If you are in online programmer mode, 
you can also use RVTs to change the values of reference data. In the Project tab 
of the  Navigator, the Reference View Tables folder contains a Default 
Tables folder. You can add user-defined tables to the Reference View Tables 
folder. A target can have zero or more user-defined RVTs.

You can configure the default appearance of your RVTs in the Options tab of the 
Navigator. For more information, see “Options”, on page 23.

Data values at sequential addresses are displayed from right to left, by default, 
starting at the reference address specified in the Address column. Both default and 
user-defined RVTs display rows of 8 cells for discrete memory (each cell 
corresponding to 8 bits) and rows of 10 cells for register memory (each cell 
corresponding to one 16-bit register). The amount of data displayed in the columns 
depends on the data display format. 

T o  c r ea t e  a  u s e r - d e f i n e d  R e f e r e n c e  V i e w  T a b l e
• In the  Project tab of the Navigator, right-click the  Reference View Tables folder and choose New.

A new  Reference View Table with a default name is added to the folder.

Starting AddressSelected address
Format of selected address

Display format can be 
selected for individual 
cells or the entire 
table.

This is the data at the 
starting address.

Subsequent addresses 
are displayed right to 
left by default. 
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T o  w o r k  w i t h  a  u s e r - d e f i n e d  R e f e r en c e  V i e w  T a b l e
1. In the Project tab of the  Navigator, expand the  Reference View Tables folder and double-click the 

table you want to view. 

The Reference View Table appears in the main Machine Edition window.

2. Add reference addresses to the table as required.

Note: You cannot add reference addresses to a default RVT.

3. Format the table entries as desired.

R e p o r t s  

Reports provide summaries and tables of information about your project. Most 
reports are displayed in the InfoViewer (see page 24). The Reports tab of the 

Feedback Zone contains a list of all reports generated since the last Machine 
Edition project was opened. The following are types of reports and logic printouts 
available in Logic Developer - PLC:

An asterisk (*) indicates a logic printout. 

T o  g e n e r a t e  r ep o r t s  
• In the Project tab of the Navigator, right-click a node and choose Report to generate a report on that 

node.

A report is automatically generated and displayed in the InfoViewer. 

Note: To generate an Online Force report for a target, you must be online to the 
target PLC. Right-click the target, point to Online Commands, and then choose 
Online Force Report.

Want to know more? In the online help index, look up “RVT”, then select “Working with user-
defined Reference View Tables” or “Working with default Reference View Tables”.

Address Use report Online Force Report IL block report *

Application Structure reports Variables reports LD block report *

EGD reports Local Logic block report *

Hardware Configuration report Motion block report *

Modbus Address report CAM profile report Structured Text Blocks *

Navigator: Project Tab

Reference View Table node
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T o  r e d i s p l ay  a  p r ev i ou s l y  g e ne r a t e d  r e po r t  
1. In the  Feedback Zone, double-click the Reports tab. 

A list of previously generated reports appears in the Feedback Zone.

2. In the list, click the report you want to view.

The report displays in the InfoViewer. 

Many items in a report contain hyperlinks. Click a hyperlinked item to jump to that 
item in the project. For example, if a variable's name appears hyperlinked in a 
report, clicking it selects that variable in the Variables tab of the Navigator. 

Large reports are often separated into several pages. To view a different page of the 
report, scroll to the bottom of the report in the InfoViewer and click the number of 
the page you want to view.

T o  p r i n t  a  r ep o r t  d i s p l ay e d  i n  t h e  I n f o V i e w e r  
1. Generate the report you want to print, or redisplay a previously generated report.

2. When the report is displayed, right-click the InfoViewer window and choose Print.

T o  p r i n t  LD  B l o c k s
1. In the Project tab of the Navigator, expand the  Logic node. 

2. Right-click the  Program Blocks node and choose Print LD Blocks.

The Print dialog box appears.

3. Select the blocks to print. 

■ To print all of the target's LD blocks, select the All option. 

■ To print only some of the target's LD blocks, select the Selection option, then 
select the check box in front of each block you want to print. 

4. Select options as required and click OK.

T o  p r i n t  S T  b l o c k s
1. In the Project tab of the Navigator, expand the  Logic node. 

2. Right-click the  Program Blocks node and choose Report of ST Blocks.

The Structured Text Blocks logic printout is automatically generated and displayed 
in the InfoViewer. 

Want to know more? In the online help index, look up “Reports” and “printing LD logic”.
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Logic Developer - PLC supports several GE Fanuc PLC families and various GE 
Fanuc remote I/O interfaces (see page 72) with a variety of CPUs, racks, and 
modules for each. In order to operate, GE Fanuc PLC hardware must be configured 
with Logic Developer - PLC or some other GE Fanuc tool. The HWC component of 
Logic Developer - PLC provides a way to configure your target equipment. This 
chapter details specifics on configuring PLC hardware for your operational needs. 

The first step in configuring PLC hardware is to select the PLC you want to 
configure (see page 30). When creating a new project, you can use a project 
template containing a default Hardware Configuration, or you can create an empty 
project and configure it manually.

P A C S Y S T E M S  R X 3 I
The PACSystems RX3i, pictured below, is the newest family of GE Fanuc PLCs. The 
PACSystems RX3i is an upward compatible upgrade for Series 90-30 PLCs, offering 
more memory, faster clock speed, and an enhanced backplane bus.

The PACSystems RX3i consists of a main rack and up to seven expansion racks. Six 
types of Series 90-30 expansion racks are supported; they have IC693CHSnnn 
catalog numbers and are colored black, in keeping with the Series 90-30 color 
scheme. Two expansion racks have IC694CHSnnn catalog numbers. These are 
identical to the IC693CHSnnn expansion racks of the same numbers except that 
they are colored blue, in keeping with the PACSystems RX3i color scheme.

I/O Modules

Rack

Power Supply

CPU
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The main rack and all expansion racks support most Series 90-30 modules; these 
have IC693NNNnnn catalog numbers and are colored black, in keeping with the 
Series 90-30 color scheme. Almost all of the IC693NNNnnn modules supported 
by PACSystems RX3i also come as IC694NNNnnn modules that have identical 
functionality. The only difference is that the IC694NNNnnn modules are colored 
blue, in keeping with the PACSystems RX3i color scheme. For example, the 
IC693DSM314 and IC694DSM314 are functionally identical and both can be used 
interchangeably in a Series 90-30 rack system or a PACSystems RX3i rack system. 
The only hardware difference is their color.

When you configure a PACSystems RX3i rack system, you can select 
IC693NNNnnn or IC694NNNnnn racks or modules. When you configure a Series 
90-30 rack system, however, you can select only IC693NNNnnn racks or modules. 
Even if you are physically using IC694NNNnnn racks or modules, selecting 
IC693NNNnnn racks or modules in Logic Developer - PLC is adequate.

The PACSystems RX3i default main rack, IC695CHS012, has 13 slots: Slots 0 
through 12. The alternate main rack, IC695CHS016, contains 17 slots: Slots 0 
through 16. 

On either main rack, slot 0 is reserved for a power supply or the CPU, but the 
power supply or CPU does not have to be in slot 0. The last slot is reserved for the 
Serial Bus Transmitter module (IC695LRE001). The slot just before the last slot can 
contain any single-width module native to PACSystems RX3i (IC695...) except the 
Serial Bus Transmitter. Any other slot can contain any single-width module native 
to PACSystems RX3i (IC695...) except the Serial Bus Transmitter, and if the next slot 
is empty, they can contain any supported double-width module. 

The IC695PSA040 power supply and the CPU are two-slot modules. The 
IC695PSD040 power supply is a one-slot module. PACSystems RX3i supports 
many Series 90-30 modules: each one occupies a single slot.
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C o n f i g u r i n g  P A C S y s t e m s  R X 3 i  H a r d w a r e

When you create a target with a PACSystems RX3i rack system, the default HWC 
consists of the main rack, with a power supply in slots 0 and 1, and a CPU in slots 
2 and 3. You can replace the default power supply. You can replace the CPU with 
itself to update it to the latest catalog version, that is, the latest set of properties 
supported for the CPU in Logic Developer - PLC. You can move the power supply 
and the CPU to any empty slot in the target with an adjacent empty slot; however, 
the second adjacent slot cannot be the last slot. You can add up to seven 
expansion racks, and on each of these, you can add IC693NNNnnn modules and 
the IC694NNNnnn that are supported by Series 90-30.

Note: On PACSystems RX3i targets, only the main rack is added by default. On 
Series 90-70 and Series 90-30 PLCs, seven expansion racks are added by default to 
the HWC. You do not need to add them.

Navigator: Project Tab displaying the 
HWC node of a PACSystems RX3i
GFK-1918G Proficy Logic Developer - PLC 5.50 51
sales@roc-electric.com   www.roc-electric.com



H a r d w a r e  C o n f i g u r a t i o n

PACSystems RX7i4
P A C S Y S T E M S  R X 7 I
The PACSystems RX7i is pictured below.  

The PACSystems RX7i consists of a main rack and up to seven expansion racks. The 
PACSystems RX7i supports a few types of main racks. It supports five types of Series 
90-70 expansion racks. All main racks and expansion racks support a few non-
intelligent Series 90-70 fan kits.

The PACSystems RX7i main racks have 10 or 18 single-width VME slots. Slot 0 
supports one of the power supply modules. Slots 1 and 2 are used to house a 
double-width CPU. PACSystems RX7i supports a few CPU models. Each 
PACSystems RX7i CPU has an embedded Ethernet adapter. In addition to the 
Ethernet adapter, up to three IC698ETM001 Ethernet modules can be installed in a 
PACSystems RX7i main rack. The Ethernet modules occupy only one slot. All of the 
IC698... modules are supported only on the main rack.

PACSystems RX7i supports most Series 90-70 modules. Most Series 90-70 modules 
are double-width, that is, they occupy two slots on the main rack, but they occupy 
only one slot on a Series 90-70 expansion rack. You can plug double-width 
modules into any two adjacent slots of the main rack except slots 0, 1, or 2. 
Because slot 17 is a double-width slot, any module in slot 17 occupies only slot 
17. Slot 17 can also accept a single-width module.

PACSystems RX7i supports the following Series 90-70 bus expansion modules: 

■ IC697BEM711 

■ IC687BEM713

■ IC697BEM713 

Rack

CPU

Power Supply

I/O Modules
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PACSystems RX7i also supports Series 90-70 Genius Bus Controllers, which 
support numerous Genius devices.

C o n f i g u r i n g  P A C S y s t e m s  R X 7 i  H a r d w a r e

When you create a target with a PACSystems RX7i rack system, the default 
Hardware Configuration consists of the main rack, with a power supply in slot 0 
and a single CPU in slots 1 and 2. You can replace the default power supply and 
CPU, and add single-width or double-width modules. You can add up to seven 
expansion racks, and on each of these, you can add Series 90-70 modules. 

Note: On PACSystems RX7i targets, only one rack is added by default. On Series 
90-70 and Series 90-30 PLCs, seven expansion racks are added by default to the 
HWC. You do not need to add them.

Navigator: Project Tab displaying the 
HWC node of a PACSystems RX7i
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Configuring PLC Hardware4
C O N F I G U R I N G  P L C  H A R D W A R E
The following configuration procedures focus on the PACSystems RX3i. 
Procedures for the other PLC families supported by Logic Developer - PLC are 
nearly identical. 

The default power supply for the PACSystems RX3i is the IC695PSA040. 

T o  r e p l a c e  a  p o w e r  s u p p l y
1. In the Project tab of the Navigator, right-click the  power supply slot and choose Replace Module.

A list of available power supplies appears.

Note: For non-PACSystems GE Fanuc PLC families, there is no Slot 0. Right-click 
the PWR slot instead.

2. Select the power supply you have installed in your rack and click OK. 

The default CPU specified in the project template for a PACSystems RX3i is the 
IC695CPU310. 

T o  r e p l a c e  a  C P U  
1. In the Project tab of the   Navigator, expand the Hardware Configuration. 

All racks are revealed.

2. Expand the  main rack.

3. Right-click the CPU slot and choose Replace Module.

Note: PACSystems supports only one CPU; it can be replaced with itself to update 
it to the latest catalog version, that is, the latest set of properties supported for the 
CPU in Logic Developer - PLC.HWC right-click menu
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The Module Catalog dialog box appears.

4. From the list, select a CPU. 

5. Click OK.

A dialog box appears asking if you want to retain the settings from the existing 
CPU.

6. Click Yes or No.

The target is configured with the selected CPU.

T o  c o n f i g u r e  a  C P U
1. In the  Project tab of the  Navigator, right-click a slot containing a CPU and choose Configure.

The Parameter editor displays all configurable settings for the CPU.

2. Modify the settings as required. For information on any parameter of a PACSystems CPU, select the parameter. 

Help topics for PACSystems CPU parameters appear in the Companion. 
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Configuring PLC Hardware4
Tip: To open the Companion, press SHIFT+F11 or click  on the Tools toolbar (see 
page 17).

T o  a dd  a n  e xp an s i o n  r a c k  ( PA C S y s t e ms  o n l y )
Note: On Series 90-70 and Series 90-30 PLCs, seven expansion racks are added by 
default to the HWC. You do not need to add them.

1. In the  Project tab of the  Navigator, right-click the  Hardware Configuration and choose Add Rack.

The Module Catalog dialog box appears listing available rack types.

2. Select a rack and click OK. 

The Series 90-30 expansion rack is added to the PACSystems RX3i rack system. It is 
assigned an available number in the range of 1 through 7, excluding numbers 
already assigned to other expansion racks.

To  r e p l a c e  a  r a c k
1. In the  Project tab of the  Navigator, right-click a  rack and choose Replace Rack.

The Module Catalog dialog box appears listing available rack types.

2. Select a rack and click OK. 

Navigator: Project tab

PACSystems HWC configuration

Navigator: Project tab

HWC configuration
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T o  a d d  a  f a n  k i t  t o  a  r a c k  ( P A C S y s t e m s  R X 7 i  o n l y )
1. In the Project tab of the Navigator, expand the  Hardware Configuration.

2. Right-click a  rack and choose Properties.
The Inspector displays the rack’s properties.

3. In the Inspector, click the Fan Catalog Number property.
The  button appears to its right.

4. Click the  button.

The Fan Kits catalog appears.

5. Select the fan kit you want to add and click OK.

The fan kit is added to the rack.

T o  a d d  a n  E t h e r n e t  mo d u l e  ( P A CS y s t em s  o n l y )
1. In the Project tab of the Navigator, expand the Hardware Configuration and then  Rack 0 (the 

main rack).

2. Double-click the slot you want to add an Ethernet module to, or right-click it and choose Add Module.
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Configuring PLC Hardware4
The Catalog appears.

3. In the Communications tab of the Catalog, select the Ethernet Module and click OK.

The Ethernet module is added to the slot.

4. Double-click the Ethernet module.

The Parameter editor appears.

5. Configure the Ethernet module’s parameters as needed.

T o  c o n f i g u r e  t h e  E t h e r n e t  d a ug h t e r b oa r d  ( P AC S y s t em s  R X 7 i  o n l y )
1. In the Project tab of the Navigator, expand the Hardware Configuration, then  Rack 0 (the main 

rack), and then  Slot 1.

2. Double-click  Ethernet.

The Parameter editor appears.

3. Configure the Ethernet daughterboard’s parameters as needed.

Want to know more? In the online help index, look up “configuring PACSystems RX3i rack 
system”.

Navigator: Project tab PACSystems 
Ethernet Adapter
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T o  m o v e  a  m od u l e
1. In the Project tab of the Navigator, expand the Hardware Configuration and then the rack 

that contains the module.

2. Do one of the following:

■ To move the module from one target to another: press SHIFT while dragging and 
dropping the module onto an appropriate empty slot.
- or -

■ To move the module within a target: drag and drop the module onto an 
appropriate empty slot without pressing any keys.

You cannot move modules between different types of PLC targets, for example 
from a Series 90-30 to a PACSystems RX7i.

The module is removed from the original slot and inserted into the empty slot.

Notes: (PACSystems) 

■ You can drag a double-width module to a main rack slot only if both the slot 
and the slot after it are empty. Exceptions: The last slot on a PACSystems RX7i 
can contain a double-width module or one single-width module. The last slot 
on a PACSystems RX3i can contain only an IC695LRE001.

■ Only PACSystems RX3i supports moving a power supply or CPU module.

T o  c o p y  a  m o d u l e
1. In the Project tab of the Navigator, expand the Hardware Configuration and then the rack that 

contains the module.

2. Do one of the following:

■ To copy the module from one target to another: drag and drop the module onto 
an appropriate empty slot without pressing any keys.
- or -

■ To copy the module within a target: press CTRL while dragging and dropping 
onto an appropriate empty slot.

You cannot copy modules between different types of PLC targets, for example from 
a Series 90-30 to a PACSystems RX7i.

A copy of the module is inserted into the empty slot.

Notes: (PACSystems) 

■ You can drag and drop a double-width module to a main rack slot only if both 
the slot and the slot after it are empty. Exceptions: The last slot on a PACSystems 
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I/O variables4
RX7i can contain a double-width module or one single-width module. The last 
slot on a PACSystems RX3i can contain only an IC695LRE001.

■ Only PACSystems RX3i supports copying a power supply.

I / O  V A R I A B L E S
An I/O variable is a variable mapped to a terminal in the Hardware Configuration 
of a PACSystems. A terminal, for example, can be one of the following: 

✐ A physical I/O discrete or analog point on a PACSystems module or on a 
Genius device

✐ A discrete or analog status returned from a PACSystems module
✐ Genius global data

Memory required to support I/O variables counts against your user memory. When 
you configure the PACSystems CPU (see page 55), select the Memory tab and set 
the I/O Discrete (# of Bits) and I/O Non-Discrete (# of Words) parameters to 
configure the space available for I/O variables.

T o  e n a b l e  I /O  va r i a b l e s  f o r  a  m od u l e
1. In the  Project tab of the  Navigator, expand the target that contains the module.

2. Expand the  Hardware Configuration and expand the  rack that contains the module. 

3. Right-click the module and choose Properties.
The Inspector displays the module’s properties.

4. In the Inspector, set the Variable Mode property to True.

If the Variable Mode property is read-only and set to False, the module doesn't 
support I/O variables.

5. In the dialog box that appears, click Yes.

If you enable I/O variables for a Genius bus controller, I/O variables are enabled 
for all the Genius devices on the Genius bus.
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Note: When you enable I/O variables for a module, the Hardware Configuration 
and logic become coupled. This means that they must be downloaded, uploaded, 
or cleared together. You cannot change or add I/O variables in Run Mode Store.

T o  m a p  a  v a r i a b l e  t o  a  t e r m i n a l  i n  t h e  T e rm i n a l s  t a b  o f  a  modu l e  o r  G en i u s  d e v i c e
1. In the  Project tab of the  Navigator, expand the target that contains the module or Genius device.

2. Expand the  Hardware Configuration and expand the  rack that contains the module or device. 

3. Double-click the module or expand the Genius Bus Controller (GBC) and double-click the Genius device.

The Parameter editor displays the Terminals tab of the module or device.

4. In the Terminals tab, right-click a terminal node that has no I/O variable mapped to it and choose Map Variable.
The Variables smart list appears.

5. In the smart list, do one of the following:

■ Enter a name that is not used elsewhere in the PACSystems target. A new I/O 
variable by that name is created and mapped to the terminal. Its Ref Address 
property is set to an I/O variable address. If the terminal is discrete, the new I/O 
variable’s data type is set to BOOL. If the terminal is analog, the data type is set 
to INT, but you can change it to another 16-bit data type: UINT or WORD.
- or -

■ Enter the name of an existing CPU-mapped variable, symbolic variable, or alias 
variable. (There are some mapping limitations.) The variable becomes an I/O 
variable mapped to the terminal and its Ref Address property is changed 
accordingly.

Want to know more? In the online help index, look up “I/O Variables (PACSystems)”, 
“working with I/O variables (PACSystems)”, and “Coupled Hardware Configuration and 
Logic”.
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Redundancy Systems4
R E D U N D A N C Y  S Y S T E M S
Redundancy systems apply only to Series 90-70 PLCs and PACSystems RX7i. In 
redundancy systems, two units are set up and configured identically. If one unit 
fails or is taken offline, the other unit assumes responsibility without interrupting 
operation of the entire system.

There are three types of redundancy systems:

■ Basic CPU Redundancy

■ Genius Redundancy 

■ CPU Redundancy Over Genius

B a s i c  C P U  R e d u n d a n c y
To implement basic CPU redundancy, a single Logic Developer - PLC target is 
associated with two physical PLCs, a Primary and a Secondary. Both PLCs share 
the same logic, but each has its own  Hardware Configuration (HWC): Primary 
or Secondary. The selected HWC is the HWC that you can go online with, 
download to, upload from, and so on.

Three types of basic CPU redundancy are available. These redundancy systems can 
be used in combination with Genius redundancy schemes.

■ Single Bus with Preferred Master (Series 90-70 CPUs CGR772 and CGR935 
only): uses a single Genius bus with one or more bus controllers in each PLC. 
The primary unit is always chosen as the active unit when the units initially 
synchronize.

■ Single Bus with Floating Master (PACSystems RX7i and Series 90-70): uses a 
single Genius bus with one or more bus controllers in each PLC. No switchover 
occurs on initial synchronization to make the primary unit the active unit.

■ Dual Bus with Floating Master (PACSystems RX7i and Series 90-70): uses dual 
busses with one or more bus controllers in each PLC. No switchover occurs on 
initial synchronization. Bus Switching Modules (BSMs) are required in 
accordance with configuration of a dual bus network. This option provides 
redundancy of both the CPU and the Genius bus.

Navigation: Project Tab
HWC Node

CPU Redundancy
(Series 90-70 and PACSystems RX7i only)
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G e n i u s  R ed u n d a n c y
A Genius redundancy system contains duplicate components that are configured 
to keep the Genius system operating properly even if one of the duplicate 
components fails or is taken out of service. Genius redundancy systems can be 
used in combination with PACSystems RX7i and Series 90-70 CPU redundancy 
systems.

You can configure five types of Genius redundancy systems: 

■ Genius dual bus redundancy (paired GBC internal)

■ Genius dual bus redundancy (paired GBC external)

■ Genius dual GBC redundancy (paired GBC internal)

■ Genius dual GBC redundancy (paired GBC external)

■ Genius dual bus & dual GBC redundancy

C P U  R e d u n d a n c y  O ve r  G e n i u s
A CPU Redundancy Over Genius system contains duplicate components that are 
configured to keep the system operating properly if one of the duplicate 
components fails or is taken out of service.

Five types of CPU Redundancy Over Genius systems can be built upon the various 
types of redundancy Genius systems combined with the basic CPU Redundancy 
schemes.
■ CPU redundancy (GHS) using Genius dual GBC redundancy (paired GBC 

external): Single bus with preferred master (Series 90-70 only)

■ CPU redundancy (HSB/GDB) using Genius dual GBC redundancy (paired GBC 
external): Single bus with floating master

■ CPU redundancy (HSB/GDB) using Genius dual bus redundancy (paired GBC 
external): Single bus with floating master

■ CPU redundancy (HSB/GDB) using Genius dual bus and dual GBC 
redundancy: Dual bus with floating master

■ CPU redundancy (HSB/GDB) using a mixed Genius redundancy scheme

Want to know more? In the online help index, look up “Redundancy: an Overview”.
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C o n f i g u r i n g  R e d u n d a n c y  S y s t e m s

The procedures below are the general steps to follow for configuring redundancy 
systems. For the procedures on configuring specific redundancy systems, see the 
online help.

T o  s e t  u p  t h e  p r im a r y  Ha r dw a r e  C on f i g u r a t i o n  f o r  C PU  r e du n da n cy  ( PA C S y s t e m s  R X 7 i  a n d  S e r i e s  9 0 -7 0 )
1. In the Project tab of the Navigator, expand the  target for which you want to set up CPU redundancy.

2. Right-click Hardware Configuration, point to Redundancy, and choose Wizard.

The Redundancy Wizards dialog box appears, with the Set up a Primary Hardware 
Configuration for CPU Redundancy option selected by default.
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3. Click Next and follow the wizard to the end. The wizard adds a redundancy CPU and other redundancy modules to 
the configuration.

The target property, Dual HWC, is now available in the Inspector and is set to False 
by default.

T o  a d d  G e n i u s  B us  C o n t r o l l e r s  ( GB C )  t o  y ou r  s y s t e m  ( PA C S y s t e m s  R X 7 i  a n d  S e r i e s  9 0 - 7 0 )
1. In the Project tab of the Navigator, expand the  target for which you want to set up Genius 

redundancy.

2. Right-click Hardware Configuration, point to Redundancy, and choose Wizard.
The Redundancy Wizards dialog box appears.

3. Select Add GBCs for Genius Redundancy.
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Redundancy Systems4
4. Click Next and follow the wizard to the end. The wizard enables you to select a Genius redundancy system and the 
location of the GBC modules. You can run this wizard multiple times to configure additional pairs of redundancy 
busses in the same system.

Note: When you add a Genius Bus Controller (GBC) to a PACSystems RX7i or 
Series 90-70 rack, a new Genius bus network is automatically created and 
associated with that slot and GBC module. Up to 31 Genius I/O devices (blocks) 
can be connected to a GBC through its Genius bus. 

T o  c o n f i g u r e  t h e  s e c on d a ry  H a r dw a r e  C on f i g u r a t i o n  ( P A CS ys t em s  R X 7 i  a n d  S e r i e s  9 0 - 7 0 )
1. In the Project tab of the Navigator, select the Hardware Configuration.

2. Right-click Hardware Configuration, point to Redundancy, and choose Mirror to Secondary Hardware 
Configuration. 
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A secondary rack system that is a copy of the primary rack system is generated. The 
target now displays two Hardware Configurations (HWCs), one labeled [Primary] 
and the other, [Secondary]. The Primary HWC is bolded because it is currently 
selected. The target property Dual HWC is now set to True. To select which 
controller to interact with, set the Selected HWC property, just below the Dual 
HWC property.

Note: You can mirror as many times as necessary to synchronize the two HWCs 
after modifying the primary HWC. Each time you mirror the primary HWC, the 
secondary HWC is updated to reflect those changes. 

Want to know more? In the online help index, look up “Redundancy: an Overview”.
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PACSystems RX3i and Series 90-30: DSM324i and Motion Mate DSM314 Motion 4
P A C S Y S T E M S  R X 3 I  A N D  S E R I E S  9 0 - 3 0 :  
D S M 3 2 4 I  A N D  M O T I O N  M A T E  D S M 3 1 4  
M O T I O N  M O D U L E S
The Series 90-30 PLC family supports various I/O modules (discrete input, discrete 
output, discrete mixed, analog input, analog output, and analog mixed), 
communication modules, intelligent modules, bus controllers, and motion 
modules. You configure Series 90-30 hardware as described in the section 
“Configuring PLC Hardware”, on page 54.

PACSystems RX3i and Series 90-30 support some Motion modules that no other 
GE Fanuc PLC family supports: the DSM324i and the Motion Mate DSM314 (see 
page 133). Both are high performance, easy-to-use multi-axis motion control 
modules. Compatible with PLC logic solving and communications functions, the 
DSM314 supports the following servo types:

■ Digital - GE Fanuc digital servo amplifiers and motors.

■ Analog - GE Fanuc SL Series analog servos and third-party servos.

The DSM324i supports only the Digital servo types. 

Both the DSM324i and the Motion Mate DSM314 modules have four axes that can 
be individually configured in Standard or Follower mode. 

In order to perform motion programming in Logic Developer - PLC, you must 
program a DSM324i or a Motion Mate DSM314 module (see page 133). 

T o  a d d  a  D S M 3 2 4 i  o r  Mo t i o n  M a t e  D S M 3 14  mo d u l e
1. With a rack of the Hardware Configuration node expanded, right-click the empty slot you want to add a 

DSM324i or a Motion Mate DSM314 module to and choose Add Module.

The Catalog dialog box appears.

2. In the Catalog dialog box, click the Motion tab.

A selection of motion modules appears in the Catalog dialog box.

3. From the list, select DSM324i or Motion Mate DSM314.
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The following picture displays the selections available for a PACSystems RX3i.

4. Click OK.

As per the example illustration, an IC693DSM314 is added to the Hardware 
Configuration of your project. 

T o  c o n f i g u r e  a  D S M3 2 4 i  o r  a  Mo t i o n  M a t e  D S M 3 14  
1. In the Project tab of the  Navigator, double-click the slot containing a DSM324i or Motion Mate DSM314. 

The Parameter editor appears.

2. Configure the DSM324i or Motion Mate DSM314 by using the Parameter editor.. 

Want to know more? In the online help index, look up “IC693DSM314: Motion Mate 
DSM314” and “IC693DSM324: DSM324i”.
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R E M O T E  I / O

S e r i e s  9 0 - 7 0  G e n i u s  R e m o t e  I / O  S c a n n e r  

A Remote I/O Scanner (IC697BEM733) is a Genius device that is part of a Genius 
Bus system. As such, it is added as a Genius device to the Genius Bus Controller 
(GBC) and it is represented in Logic Developer - PLC by an SBA node under the 
GBC in a Series 90-70 target, as illustrated to the left. It is also represented by a 
separate target in the Machine Edition project, as illustrated below.

A Remote I/O Scanner resides in Slot 1 of the Series 90-70 main rack. I/O modules 
can be inserted into the other slots of the main rack and on all the slots of the 
expansion racks. As such, the Remote I/O Scanner is represented by a target in the 
Project tab of the Navigator, and is also represented by a module in slot 1 of the 
main rack of that target.

Navigator: Series 90-70 Remote 
I/O Scanner as a Genius device under

a GBC

Navigator: Series 90-70
Remote I/O Scanner

as a target and
as a module in Slot 1 of the main rack
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Remote I/O
T o  a d d  a  R e m o t e  I/ O  S c a n n e r  
1. In the Project tab of the Navigator, expand the Hardware Configuration and expand the  main 

rack.

2. Right-click the slot containing the Genius Bus Controller (GBC) and choose Add Genius Device.

The Choose SBA dialog box appears.

3. Select a Serial Bus Address (SBA) for the Genius device and click OK.

The Catalog appears.

4. Select the device you want to add and click OK.

The device is added to the bus configuration with the SBA you selected.

5. When prompted to add a new target for the Remote I/O Scanner, click Yes. 
A new GE Fanuc Remote I/O target appears in your project. This target 
represents the Remote I/O Scanner. In the Hardware Configuration of the new 
target, the Remote I/O Scanner also appears in Slot 1 of the main rack.

6. Configure the communication with the Remote I/O Scanner target.

7. Add and configure I/O modules for the rack system of the Remote I/O Scanner target.

8. Configure the Remote I/O Scanner module’s parameters in Slot 1 of the main rack of the Remote I/O 
Scanner target.

9. Set up the Remote I/O Scanner Genius device in the same SBA node.
The I/O Map of both Remote I/O Scanner configurations must match (at the 
Remote I/O Scanner target level and at the Remote I/O Scanner Genius Bus device 
level). Now whenever you update the I/O map on the Remote I/O Scanner, the I/O 
map is automatically updated to the GBC.

10. Download the Hardware Configuration of the new GE Fanuc Series 90-70 Remote I/O target.

11. Download the Hardware Configuration of the original GE Fanuc PLC target that contains the GBC.

Want to know more? In the online help index, look up “IC697BEM733: Remote I/O 
Scanner”.
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Remote I/O4
V e r s a M a x  R e m o t e  I / O

VersaMax remote I/O consists of a Network Interface Unit (NIU) (Ethernet, Genius 
or Profibus), and one or more I/O modules. You can use Logic Developer - PLC to 
configure this hardware. Once configured, the remote I/O can be controlled by a 
PLC or PC controller. The differentiating factor between a VersaMax remote I/O 
and a PLC is that a remote I/O is simply an input/output device with a 
communication interface. Unlike a PLC, a remote I/O has no CPU.

When working with the VersaMax Remote I/O Hardware Configuration, Logic 
Developer - PLC enables you to add racks, configure the power supply, and 
configure modules.

Remote I/O targets are generally added to a project when you create a project from 
a template. You can also add a GE Fanuc Remote I/O target to an existing project. 

T o  c r ea t e  a  p r o j e c t  c o n t a i n i n g  a  G E  F a nu c  R em o te  I /O  t a r g e t  f r o m  a  t e mp l a t e
1. From the File menu, choose New Project.

The New Project dialog box appears.

2. From the Project Template list, choose the GE Fanuc Remote I/O you want to add to your project. 

3. Enter a descriptive Project Name.

4. Click OK.

A new Remote I/O project is started. 

T o  a d d  a  G E  F a n u c  R e mo t e  I/ O  t a r g e t  t o  a n  e x i s t i n g  p r o j e c t
1. In the  Project tab of the  Navigator, right-click the Project node.

2. Point to Add Target, then to GE Fanuc Remote I/O, and choose the remote I/O you want to add. 

Note: The Series 90-70 Genius option is a Series 90-70 Remote I/O Scanner (see 
page 70).

Navigator: VersaMax Remote I/O
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Remote I/O
T o  r e p l a c e  t h e  p o w e r  s u p p l y  i n  y o u r  r e mo t e  I /O  c o n f i g u r a t i o n
1. In the Project tab of the Navigator, expand the Hardware Configuration of the remote I/O.

The Navigator displays the following:

2. Right-click the PWR slot and choose Replace Module.

The Module Catalogue dialog box appears:

3. From the list, select the power supply that you want to configure for your system.

4. Click OK.

T o  a dd  a  n e w  C a r r i e r /B as e  t o  y o u r  V e r saM ax  R em o te  I /O
1. In the Project tab of the Navigator, select a remote I/O target.

2. Expand the Hardware Configuration node and the main rack.

The Navigator displays the following:
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Remote I/O4
3. Right-click the Slot 0 node and choose Add Carrier/Base.

The Module Catalog dialog box appears.

4. Select the carrier/base that you want to add to the remote I/O target.

Note: You can add a maximum of eight carrier modules to each VersaMax rack.

5. Click OK.

T o  a dd  a  m od u l e  t o  a  c a r r i e r /b a se
1. In the Project tab of the Navigator, expand the Remote I/O target you want to add a base to.

2. Double-click an empty carrier/base.

The Module Catalog appears.

3. From the Module Catalog, select the module that you want to install.

4. Click OK.

Want to know more? In the online help index, look up “Hardware Configuration”.
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5 Logic Programs and Blocks

P r o g r a m  T y p e s

For most GE Fanuc PLCs, all the logic that is downloaded to a PLC constitutes one 
program. However, there are cases when distinctions need to be made. Therefore, 
we can speak of a main program, a C program, and a Motion program.

Each C program is a named section of executable code. The main program and 
the Motion program contain blocks; that is, named sections of executable code 
that can be written in various languages.
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The Project tab of the Navigator contains all of the programs:
✐ The main program and its blocks reside in the Program Blocks 

folder. You can create user-defined subfolders to further organize 
these blocks.

✐ C programs reside in the Logic folder.
✐ The Motion program resides in the Motion Program folder.

Main Program 

Most GE Fanuc PLCs support only a main program. The main program consists of a 
block of logic named _MAIN and optionally, all of the following kinds of blocks of 
logic, found under the Program Blocks folder in the Logic folder of a GE 
Fanuc PLC target:
■ Called blocks developed in various languages:

✐ Ladder Diagram (LD) Blocks
✐ Structured Text (ST) Blocks
✐ Function Block Diagram (FBD) Blocks
✐ Instruction List (IL) Blocks
✐ C Blocks

■ Called parameterized blocks (LD, ST, FBD, and/or C).
■ Interrupt blocks (LD, ST, FBD, C, and/or IL) scheduled to execute at certain time 

intervals or when specific memory registers reach certain values.
■ User-defined function blocks (UDFBs) in LD, ST, and FBD, of which 

independent instances with their own data structures and local memory can be 
used in logic. 

■ Specialty function blocks, like HART utilities. Like UDFBs, you can create 
independent instances of specialty functions blocks with their own instance 
data (a structure variable). Unlike UDFBs, you cannot edit the logic of specialty 
function blocks because they are read-only and provided to you by GE Fanuc. 

■ All GE Fanuc PLCs support LD blocks, but only certain PLC families or models 
support one or more of the other kinds of blocks.

Want to know more? In the online help index, look up “UDFB“ then choose “User-Defined 
Function Blocks (UDFBs) (PACSystems)”.

Want to know more? In the online help index, look up “Specialty Function Blocks 
(PACSystems)“.

 
Navigator: Project tab

Programs
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The _MAIN block can be in various languages, depending on the PLC family or 
model.

You download the main program to the PLC as logic; that is, after you initiate a 
download, a dialog box presents you with three Download to PLC options and you 
select the Logic option. If the Logic option is not present, select the Program 
option.

C Programs 

Series 90-70 CPUs firmware version 6.00 and later support either the main 
program, or various C programs, or a combination of a main program and C 
programs. You download these various programs to the PLC together as logic; that 
is, after you initiate a download, a dialog box presents you with three Download to 
RAM options and you select the Logic option.

If there is no _MAIN block, then there is no main program. In this case, you would 
have only one or more C programs and possibly various standalone interrupt 
blocks (LD or C). These standalone interrupt blocks do not constitute a main 
program if there is no _MAIN block. 

A C program can be named _MAIN only if the target contains no LD blocks. 

A C program is not the same as a C block. For more information, see “C Programs”, 
on page 125.

Motion Program 

In addition to the main program, Series 90-30 CPUs firmware version 10.00 and 
later, as well as PACSystems RX3i CPUs firmware version 2.80 and later, support a 
Motion program for use on a DSM324i or Motion Mate DSM314 module. The 
Motion program consists of:

■ CAM profiles

■ CAM blocks

■ Local Logic block

■ Motion blocks

You download the Motion program to the PLC as part of its Hardware 
Configuration (HWC); that is, after you initiate a download, a dialog box presents 
you with three Download to RAM options and you select the Hardware 
Configuration option. If you want to download the main program at the same time, 
you also select the Logic option.  If neither option is present, select the Program 
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option to download both the Hardware Configuration and the Logic. For more 
information about the Motion Program, see page 133.

N u m b e r  o f  B l o c k s  i n  t h e  M a i n  P r o g r a m

S c h e d u l i n g  P r o g r a m s  

On GE Fanuc PLCs that support only one program (the main program), the 
program as a whole cannot be scheduled. Every scan, logic execution begins with 
the _MAIN block. You can schedule individual interrupt blocks of logic but not the 
_MAIN block.

When you execute both a main program and a Motion program on a Series 90-30 
PLC with a CPU firmware version 10.00 and later, or on a PACSystems RX3i with a 
firmware version of 2.80 or later, you cannot schedule the programs because they 
are executed concurrently in two different locations.

■ In the CPU, every scan, logic execution begins with the _MAIN block of the 
main program.

■ In the DSM324i or Motion Mate DSM314 module, the Motion program 
executes independently of CPU scan times.

■ You can schedule individual interrupt blocks of logic in the main program 
(except the _MAIN block).

Series 90-70 CPUs firmware version 6.00 and later support scheduling programs. 
On targets that contain such CPUs, you can schedule any program, even the main 
program. That is, logic execution of any scan does not have to begin with the 

 CPU Type Number of Blocks Maximum Number of 
Blocks

 PACSystems 511 subroutine blocks plus one 
_MAIN block

512

 Series 90-70 255 subroutine blocks plus one 
_MAIN block

256

 Series 90-30 64 subroutine blocks plus one 
_MAIN block

65

 VersaMax PLC and 
VersaMax Micro

64 subroutine blocks plus one  
_MAIN block

65

 VersaMax Nano 8 subroutine blocks plus one  
_MAIN block

9

 Series 90 Micro 1 _MAIN block 1
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_MAIN block of the main program: you can schedule any C program to begin the 
logic execution part of the scan. Within the main program, you can further 
schedule individual interrupt blocks of logic (except the _MAIN block). If you have 
no main program, that is, if your logic has no _MAIN block, you can still have 
stand-alone interrupt blocks that you can schedule individually.

T o  s c h ed u l e  t h e  e xe c u t i o n  o f  p r og r a m s  on  a  S e r i e s  9 0 - 7 0
1. In the  Project tab of the  Navigator, right-click a  C program or the _MAIN LD block, and choose 

Properties.

The  Inspector displays the program properties. The main program properties 
(Program Name, Scheduling, and Stack Size) are shown together with the _MAIN 
block’s individual block properties.

2. In the Inspector, expand the Scheduling property.

3. Select a Schedule Mode.

4. Select the other properties used in the schedule mode you selected.

5. Click OK.

Note: If you made any entries, they are validated when you click OK. You must 
correct any errors before you can click OK to close the dialog box.

T o  c r ea t e  a  u s e r - d e f i n ed  f o l d e r
1. In the  Project tab of the  Navigator, expand the target with the main program you want to organize 

and then expand the  Logic folder.

2. Right-click the  Program Blocks folder, point to New, and choose Folder.

A new  user-defined folder appears with a default name.

3. Optionally enter a new folder name, which must be unique among the folders directly under the parent folder.

T o  s c h ed u l e  t h e  e xe c u t i o n  o f  a  b l o c k  o f  l o g i c  
1. In the  Project tab of the  Navigator, right-click an existing LD, FBD, ST, C, or IL block, and choose 

Properties.

The block’s properties appear in the Inspector. 

Want to know more? In the online help index, look up “Programs on GE Fanuc PLCs: an 
Overview”.

Want to know more? In the online help index, look up “organizing logic (main program of a 
PLC)”.
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2. In the Inspector, click the  button in the Scheduling property. 

The Scheduling dialog box appears.

3. Configure scheduling by entering values in each of the fields. 

To  c o n t r o l  a c c e s s  t o  a  b l o c k
1. Right-click an LD, ST, FBD, or IL block and choose Properties.

2. In the Inspector, expand the Lock Settings property.

3. In the Lock Type property, choose a setting from the list. 

4. In the Password property, enter a password.

To  s e a r c h / re p l a c e  i n  o n e  b l o c k  
1. Double-click an LD, ST, FBD, or IL block to open it.

2. From the Search menu, choose Find or Replace.
A dialog box appears.

3. In the Find what or in the Text to find field, enter the text to find.

4. (Only if you want to replace text.) In the Replace with field or in the New text field, enter the text to replace the 
found text with.

5. Select or clear each search/replace option, as required.

6. Click Find, Find next, Replace, Replace All, Close, or Cancel, as required.

Want to know more? In the online help index, look up “Scheduling execution of blocks of 
logic”.

Inspector: LD block properties. . 
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Note: Logic Developer - PLC enables you to search for some text in an entire target 
or portions thereof, which you can specify. Various options are available to narrow 
a search.

I n d i r e c t  R e f e r e n c e s

The LD, ST, and FBD editors support indirect references. An indirect reference 
enables you to treat the value of a variable assigned to an instruction operand as a 
pointer to other data, rather than as actual data. Indirect references are sometimes 
referred to as relative pointers.

Indirect references can be used only as follows:

■ With PACSystems CPUs and Series 90-70 CPUs.

■ In the LD, ST, and FBD editors.

■ With %R, %AI, %AQ, %P, %L, and %W memory areas.

■ On instructions that support indirect references.

Notes for PACSystems

■ The index for an indirect reference to %W is a 32-bit DWORD value.

■ Indirect references cannot be used to address bits in 16-bit memory.

■ Indirect references are not supported on symbolic variables or I/O variables.

Possible Uses

■ To perform the same operation to many registers.

■ To avoid repetitious logic within the application program.

■ In loop situations where each register is incremented by a constant or by a 
value specified until a maximum is reached.

T o  a s s i g n  a n  i n d i r e c t  r e f e r e n c e
• Where a variable operand is expected, type the @ symbol, followed by a valid reference address or variable name.

The LD, ST, or FBD editor converts a reference address to a variable name or the 
editor substitutes the name of a variable already mapped to the address.

Want to know more? In the online help index, look up “Global” and select the “Conducting a 
Global Search” help topic.
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Notes:

■ The actual variable name does not contain the @ symbol. The @ symbol, when 
used at the start of a reference address or variable name, merely indicates that 
the address or variable must be treated as an indirect reference.

■ The @ symbol can be thought of as an operator with the lowest precedence. In 
other words, MyArray[2,5] becomes a reference address that is used for the 
indirect reference. Another way to think of this is @(MyArray[2,5]) as opposed 
to (@MyArray)[2,5].

The following are valid indirect references:

■ @R0001 (a variable name automatically created from an address)

■ @MyArray[2, 5] (an array reference)

■ @$MainSwitch (a universal variable)

■ @MyTimer.PV (a structure element)
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LD Editor
L D  E D I T O R
The Ladder Diagram (LD) editor is used to create programs with the Ladder 
Diagram programming language. LD logic graphically represents the programmed 
actions performed by a PLC as it executes.

The LD editor is cell-based with rungs constructed of horizontal sequences of 
instructions that are wired together. A given instruction and its operands can 
occupy one or more cells.

You can work with the LD editor while offline to edit a disk copy of a project, or 
while online to monitor the execution of the logic while you fine tune the project, 
for example by making word-for-word changes (see page 91).

You can customize the appearance and behavior of the LD editor by setting 
options (see page 23).

An LD block is a named section of LD Logic that is compiled and downloaded to 
the PLC represented by the associated target.

To  c u s t o m i z e  t h e  L D  e d i t o r
1. In the Options tab of the  Navigator, expand the Editors folder and then the Ladder folder.

2. Right-click a  page (Confirmations, Editing, Font and Colors, or View), and choose Properties. 

The configurable options appear as properties in the Inspector.

3. In the  Inspector, adjust settings as required. 

T o  c r ea t e  a n  L D  b l o c k
1. In the Project tab of the  Navigator, right-click Program Blocks, point to New, and then choose LD 

Block. 

A new LD block with a default name is created.

2. Rename the block as desired.

To  o pe n  a n  LD  b l o c k  f o r  e d i t i n g
• In the  Project tab of the  Navigator, double-click an LD block.

The block opens in the LD editor.

Note: You can have multiple blocks open for editing. To navigate to another open 
LD block, click the tab that displays its name at the top of the editor window.

 Navigator: Project tab

An LD Block
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LD Editor5
W o r k i n g  w i t h  t h e  L D  E d i t o r  O f f l i n e
When you are offline, there is no live communication between the LD editor and 
the target. Most logic development is done while offline. The following diagram 
illustrates some of the more common operations you can perform when you use 
the LD editor offline. 

Drag variables to 
instruction 
operands to assign 
them.

Right-click to 
insert an 
instruction.

Displays a 
list of the 
places the 
selected 
variable is 
used. 

The Companion 
provides 
information on 
what you click.

Use the 
Inspector to 
configure 
address and 
length for 
instructions

Drag LD 
instructions 
from the 
Toolchest.

Insert common
instructions and
wiring with the
LD instruction
toolbar.

In-place editor
comment rungs.
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LD Editor
T o  i n s e r t  a n  i n s t r u c t i o n
1. In the LD editor, right-click an empty cell and choose Place Instruction.

A smart list appears listing all available instruction mnemonics.

2. Choose an instruction mnemonic from the list and press ENTER. 

Note: If you attempt to place an instruction that has inputs into the first column, it 
is pushed to the second column and a horizontal wire is inserted in the first 
column.

T o  a s s i gn  i n s t a n c e  d a t a  t o  a  b u i l t - i n  f u n c t i o n  b l o c k  i n s t a n c e  a nd  a s s i g n  a  l e ng t h  t o  a n  i n s t r u c t i o n  
There are two methods.

First method

1. In the LD editor, insert a built-in function block or insert an instruction that requires a Length.

For illustrative purposes, the following diagram displays a built-in function block 
instance that does double duty, because it also has a length. 

2. Right-click the function block instance or instruction and choose Properties.

The Inspector displays the instance’s or instruction’s properties.

3. In the Address property, enter a variable name or a reference address to specify the start of a memory block used 
for the instance data of the function block instance. 

Note: If you type a reference address, it is converted to a variable name 
automatically.

4. In the Length property, enter the number of bits or 16-bit registers on which the function block instance or 
instruction is to operate. 

Four question marks indicate that the Address property of the function block instance has not been initialized. As a 
result, no instance data has been assigned to the instance.

“1“ is the default value of the Length 
property of an instruction

Address Field

Length Field
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LD Editor5
Second method

1. In the LD editor, insert a built-in function block or insert an instruction that requires a Length.

2. Double-click the function block instance or instruction or select it and press ENTER.

When you double-click a function block instance, the Function Block Properties 
dialog box appears, as pictured below. When you double-click an instruction, the 
Function Properties dialog box appears, in which the Address property is 
unavailable. 

3. In the Address property, enter a variable name or a reference address to specify the start of a memory block used 
for the instance data of the function block instance.

Note: If you type a reference address, it is converted to a variable name 
automatically.

4. In the Length property, enter the number of bit or 16-bit registers on which the function block instance or instruction 
is to operate. 

T o  a s s i g n  v a r i a b l e s  t o  i n s t r u c t i o n  o p e r a n d s
1. In the LD editor, double-click beside any operand of an instruction, or click there and press ENTER.

A smart list appears prompting you to enter a variable name or reference address.

2. Type, or choose from the list, a variable name or reference address.

If you enter a reference address, a variable name will be automatically substituted.

To  c h e c k  ( va l i d a t e )  a  s i n g l e  L D  b l o c k
1. In the Project tab of the Navigator, expand the target that contains the block to check, and then 

expand the Logic folder.

2. Expand the Program Blocks folder and then, if the block resides in a user-defined folder, expand the user-
defined folder.

3. Right-click the block and choose Check Block.

Machine Edition checks the block for errors. Any messages or errors are displayed 
in the Build tab of the Feedback Zone.
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LD Editor
E d i t i n g  L o g i c  a s  T e x t

You can enter LD logic into the LD editor by starting to type right into a cell. A 
smart list appears and you can continue to type your instructions and operands. 
When you press ENTER, the logic you typed appears in customary graphic form in 
the LD editor. For example, in the first cell of a new rung, if you type “AD MyDint1 
MyDint2 Result12;AD MyDint3 MyDint4 Result34“, the following logic appears in 
the LD editor:

A horizontal wire was inserted in the first cell to make room for the ADD_DINT 
instruction’s operands and the operands were inserted in their proper places. In the 
keyboard entry, “AD“ stood for “ADD_DINT“, because ADD_DINT is the first 
available instruction that begins with “AD“ in the smart list. A semicolon separates 
the ADD_DINT instructions. The required horizontal wires are supplied 
automatically.

A powerful extension of typing logic into the LD editor is the ability to write LD 
logic in any text editor and copy and paste it into the LD editor, or to copy and 
paste logic from the LD editor to a text editor. You can copy an entire block of LD 
logic from the Navigator to any text editor, or copy sections of LD logic as text from 
the LD editor to any text editor. You can then edit the logic in the text editor and 
copy the edited logic back into the LD editor.

When LD logic is copied as text, a verbose format is used to make it easier to read, 
but when you edit the logic as text you can use the same shorthand used in the 
keyboard method of entering LD logic in the LD editor.

T o  c o p y  a n  e n t i r e  L D  b l o c k  a s  t e x t
1. In the  Project tab of the  Navigator, expand the target and expand the  Logic folder.

2. Expand the  Program Blocks folder and, if the LD block resides in a  user-defined folder, expand the user-
defined folder.

3. Optionally right-click the LD block and choose Check Block. This validates the LD block. If the logic contains errors, 
error messages appear in the Feedback Zone. If the logic contains errors, fix them.

4. Right-click the LD block and choose Copy.

Want to know more? In the online help index, look up “Keyboard Method (to insert LD 
instructions)”.
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The content of the LD block is copied to the Windows Clipboard.

5. Paste the content of the Windows Clipboard into a text editor.

The LD logic is pasted as text.

T o  c o p y  a  s e c t i o n  o f  L D  l o g i c  a s  t e x t
1. Optionally right-click the LD block and choose Check Block. This validates the LD block. If the logic contains errors, 

error messages appear in the Feedback Zone. If the logic contains errors, fix them.

2. In the LD editor, select the cells that contain the logic you want to copy as text.

3. Right-click the selected logic and choose Copy.

The LD logic is copied to the Windows Clipboard.

4. Paste the content of the Windows Clipboard into a text editor.

The LD logic is pasted as text.

T o  c o p y  t ex t  i n t o  t h e  L D  e d i t o r
1. In the text editor, select and copy the text representing LD logic to the Windows clipboard.

2. In the LD editor, do one of the following:

■ Select the cells that you want to overwrite.

- or -

■ Click the cell that will be at the upper left corner of the LD logic you want to 
paste.

3. Right-click and choose Paste.

Existing cells in the LD editor are overwritten with the content of the Windows 
clipboard.

T o  m o v e  o r  d u p l i c a t e  L D  l o g i c
1. In the LD editor, select a range of logic.

2. To move it:

■ Click the selection and drag it to a new location. 

- or -
To duplicate it:

■ Press CTRL while clicking the selection, and drag the selection to where you 
want to place the duplicate.

When you release the mouse button, the selection is respectively moved to the 
new location or a duplicate copy of the selected logic is placed in the new area. 

Want to know more? In the online help index, look up “Copying LD Logic as Text: overview”.
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W o r k i n g  w i t h  t h e  L D  E d i t o r  O n l i n e

When online in monitor mode, you can monitor the PLC but cannot change 
anything in the PLC or edit your logic. The LD editor animates LD logic to reflect 
program execution in the PLC. Data values change typically every 250 
milliseconds while coils and contacts indicate power flow. The number of 
milliseconds is set in the Update Rate target property. (See “To configure a PLC 
target”, on page 31.)

When you are online in programmer mode, you can edit your logic, make changes 
in the PLC, and monitor the PLC. Many GE Fanuc targets also support Run Mode 
Store; that is, they support the downloading of logic to a running target.

See “Offline, Online: monitor mode, programmer mode”, on page 39

.

Online Status 
is indicated 
by the color 
of the target 
icon.

Rung Number State flow is indicated by bolded lines. The contacts and coils that are set to ON 
become green when the PLC is active. 

Monitor and change values in real-time with the Data 
Watch tool.

Feedback Zone 
indicates the status of  
operations like 
downloads.

A red, underlined 
variable indicates that it 
has been forced ON.

PLC status is indicated in the status 
bar.

Right-click a 
variable to 
force it. 

PLC status 
and sweep 
time are 
displayed in 
real-time in 
the Inspector.

Online status is indicated by 
the lightning bolt.
GFK-1918G Proficy Logic Developer - PLC 5.50 89
sales@roc-electric.com   www.roc-electric.com



L o g i c  P r o g r a m s  a n d  B l o c k s
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Three methods are at your disposal to make changes in your LD logic and 
download the changes to an online running PLC:
■ Test Edit (PACSystems only). See page 90.

■ Word-for-word changes: see page 91. 

■ Go not equal, keep working, and download changes: see page 92.

You can also affect BOOL variables during execution. See page 92.

T e s t  E d i t  ( P A C S y s t e m s  o n l y )

Test Edit enables you to perform transacted online programming. That is, it enables 
you to modify an LD block in the LD editor while seeing both the original and 
modified logic, test the new logic's execution on the PACSystems, and then either 
keep the modified logic or roll back to the original logic.

T o  b eg i n  e d i t i n g  i n  T e s t  E d i t
1. In the LD editor, start modifying the logic. 

The Logic Change Options dialog box appears. 

2. Select Enter Test Edit Mode and click OK.
The LD editor is placed in Online Edit mode, with some visual cues to remind you 
that a Test Edit session is in progress. Because Test Edit is an extension of the Run 
Mode Store (RMS), only changes supported for an RMS are supported in Test Edit 
mode. At any time, you can test the modified logic.

T o  b eg i n  t e s t i n g  t h e  m od i f i e d  l o g i c
1. Click anywhere inside the LD editor.

2. From the Debug menu, choose Begin Test.
The modified logic is downloaded to the PACSystems, which then executes the 
modified logic. The original block of logic is retained in PACSystems memory as an 
inactive block.
You now have three possible courses of action:

■ Cancel the test and continue editing the logic while in Test Edit mode.

■ Cancel Test Edit mode and restore the original logic in the PACSystems.

■ Accept the changes you tested and commit them to the PACSystems.

T o  c a n c e l  t h e  t e s t  a n d  c o n t i n u e  e d i t i n g  t h e  l o g i c  w h i l e  i n  T e s t  E d i t  m o d e
1. Click anywhere inside the LD editor.
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2. From the Debug menu, choose Cancel Test.
The modified logic block is deactivated in the PACSystems. The original block is 
activated and executed. The modified logic block retains its changes in the LD 
editor and you can continue editing it and test it again later.

T o  c a n c e l  T e s t  E d i t  m od e  a n d  r e s t o r e  t h e  o r i g i n a l  l o g i c  i n  t h e  PA C S y s t e m s
1. Click anywhere inside the LD editor.

2. From the Debug menu, choose Cancel Edit.
If you made no changes to logic, the Test Edit session ends immediately. If you 
made any changes to logic, the Cancel Test Edit dialog box appears.

3. In the Cancel Test Edit dialog box, select one of the following options and click OK.

■ Restore original logic in editor and maintain equality: The PACSystems 
deactivates and deletes the modified block of logic, and it activates and 
executes the original block. The LD editor discards the modified logic from the 
block, retaining only the block's original logic. Your Test Edit session ends. You 
are online in programmer mode and logic equal. 

■ Keep modified logic in editor and lose equality: The PACSystems deactivates 
and deletes the modified block of logic, and it activates and executes the 
original block. The LD editor retains the modified block of logic and no longer 
displays the original logic where it was different. Your Test Edit session ends. 
You are online in programmer mode and logic not equal.

T o  a c c e p t  t h e  c h a n g e s  y ou  t e s t e d  a n d  c om m i t  t h em  t o  t h e  PA C S y s t e ms
1. Click anywhere inside the LD editor.

2. From the Debug menu, choose Accept Edit.
The modified logic is committed to the PACSystems. The original logic is 
completely deleted from the PACSystems; it no longer exists as an inactive block. 
The Test Edit session is ended. You are online in programmer mode and logic 
equal.

W o r d - f o r - W o r d  C h a n g e s

A word-for-word is a small change in logic made while online that fits in the same 
amount of memory as the original logic. For example, changing the type of contact 
or coil or changing an operand is usually a word-for-word change.

Word-for-word changes can be completed online to PACSystems, Series 90-30, 
Series 90-70, Series 90 Micro, and VersaMax modular PLCs. (VersaMax Nano / 
Micro PLCs do not support word-for-word changes.)
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T o  m a k e  wo r d - f o r - w o r d  c h a n g e s
1. While online to a target PLC, make a change to LD logic that does not change the logic size.

2. Do one of the following: 

■ If the Logic Change Options dialog box appears, select Word-for-word change 
and click OK.
- or -

■ If the Word for Word Change dialog box appears, click Yes.

The change is downloaded to the PLC.

G o  n o t  e q u a l ,  k e e p  w o r k i n g ,  a n d  d o w n l o a d  c h a n g e s

If you make changes in logic that do not qualify for Test Edit or a word-for-word 
change, or if you choose not to enter Test Edit mode or make a word-for-word 
change, logic becomes not equal. 

To regain equality, you can download your changes to the PLC (see page 41) or 
upload the logic from the PLC (see page 42). You can generally download to the 
PLC whether the target is running or not. All PLC families support this Run Mode 
Store capability, but not every PLC in every family.

A f f e c t i n g  B O O L  v a r i a b l e s

T o  t u r n  o n /o f f  o r  f o r c e  a  v a r i a b l e
• In the LD editor, right-click a BOOL variable anywhere in LD logic and choose Force ON, Force OFF, Toggle Force, 

Turn ON, Turn OFF, or Toggle IO. 

Note: Forcing a variable ON or OFF overrides any actions the application may 
take during runtime. That is, if a variable is forced OFF (0), but LD logic is trying to 
set it to ON (1), it remains set to OFF. 

Want to know more? In the online help index, look up “Test Edit: an Overview” and “working 
online with LD editor: overview“.
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L D  I n s t r u c t i o n s

The following is a list of all LD instructions available in Logic Developer - PLC. 
Companion help indicates which PLCs support the instructions.

A d v a n c ed  M a th

B i t  Ope r a t i o n s

C o i l s

C on t a c t s

An asterisk followed by the letter P (*p) indicates the instructions exclusive to PACSystems PLCs. 
An asterisk followed by “70“ (*70) indicates the instructions exclusive to Series 90-70 PLCs. A 
simple asterisk (*) indicates the instructions shared by PACSystems and Series 90-70 PLCs and 
exclusive to them.

Want to know more? In the online help index, look up “LD Instructions”.

ACOS COS LN SQRT_DINT TAN

ASIN EXP LOG SQRT_INT

ATAN EXPT SIN SQRT_REAL

AND_DWORD* BIT_SET_DWORD* NOT_WORD SHIFTL_DWORD*

AND_WORD BIT_SET_WORD OR_DWORD* SHIFTL_WORD

BIT_CLR_DWORD* BIT_TEST_DWORD* OR_WORD SHIFTR_DWORD*

BIT_CLR_WORD BIT_TEST_WORD ROL_DWORD* SHIFTR_WORD

BIT_POS_DWORD* MASK_COMP_DWORD ROL_WORD XOR_DWORD*

BIT_POS_WORD MASK_COMP_WORD ROR_DWORD* XOR_WORD

BIT_SEQ NOT_DWORD* ROR_WORD

COIL NEGCOIL PTCOIL*p

CONTCOIL NTCOIL*p RESETCOIL

NCCOIL POSCOIL SETCOIL

CONTCON LOALR* NOCON POSCON*

FAULT* NCCON NOFLT* PTCON*p

HIALR* NEGCON* NTCON*p
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C on t r o l

C on v e r s i o n s

C ou n t e r s

D a t a  M o v e

DO_IO EXIT_FOR* PID_IND SUS_IO* SWITCH_POS*P

DRUM FOR_LOOP* PID_ISA SUSP_IO_INTR

END_FOR* MASK_IO_INTR SER SVC_REQ

BCD4_TO_INT DINT_TO_BCD8* INT_TO_REAL REAL_TO_WORD UINT_TO_REAL*

BCD4_TO_REAL DINT_TO_INT* INT_TO_UINT* TRUNC_DINT WORD_TO_REAL

BCD4_TO_UINT* DINT_TO_REAL RAD_TO_DEG TRUNC_INT

BCD8_TO_DINT* DINT_TO_UINT* REAL_TO_DINT UINT_TO_BCD4*

BCD8_TO_REAL* INT_TO_BCD4 REAL_TO_INT UINT_TO_DINT*

DEG_TO_RAD INT_TO_DINT* REAL_TO_UINT* UINT_TO_INT*

DNCTR UPCTR

BLK_CLR_WORD BUS_TS_BYTE*P DATA_INIT_UINT* SWAP_WORD*

BLKMOV_DINT* BUS_TS_DWORD*P DATA_INIT_WORD* VME_CFG_READ*70

BLKMOV_DWORD* BUS_WRT_BYTE*P MOVE_BOOL VME_CFG_WRITE*70

BLKMOV_INT BUS_WRT_DWORD*P MOVE_DINT* VME_RD_BYTE*70

BLKMOV_REAL BUS_WRT_WORD*P MOVE_DWORD* VME_RD_WORD*70

BLKMOV_UINT* COMM_REQ MOVE_INT VME_RMW_BYTE*70

BLKMOV_WORD DATA_INIT_ASCII* MOVE_REAL VME_RMW_WORD*70

BUS_RD_BYTE*P DATA_INIT_COMM* MOVE_UINT* VME_TS_BYTE*70

BUS_RD_DWORD*P DATA_INIT_DINT* MOVE_WORD VME_TS_WORD*70

BUS_RD_WORD*P DATA_INIT_DLAN SHFR_BIT VME_WRT_BYTE*70

BUS_RMW_BYTE*P DATA_INIT_DWORD* SHFR_DWORD* VME_WRT_WORD*70

BUS_RMW_DWORD*P DATA_INIT_INT* SHFR_WORD

BUS_RMW_WORD*P DATA_INIT_REAL* SWAP_DWORD*
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D a t a  T a b l e

M a th

ARRAY_MOVE_BOOL FIFO_WRT_WORD* SEARCH_GE_UINT* SEARCH_NE_DINT

ARRAY_MOVE_BYTE LIFO_RD_DINT* SEARCH_GE_WORD SEARCH_NE_DWORD*

ARRAY_MOVE_DINT LIFO_RD_DWORD* SEARCH_GT_BYTE SEARCH_NE_INT

ARRAY_MOVE_DWORD* LIFO_RD_INT* SEARCH_GT_DINT SEARCH_NE_UINT*

ARRAY_MOVE_INT LIFO_RD_UINT* SEARCH_GT_DWORD* SEARCH_NE_WORD

ARRAY_MOVE_UINT* LIFO_RD_WORD* SEARCH_GT_INT SORT_INT*

ARRAY_MOVE_WORD LIFO_WRT_DINT* SEARCH_GT_UINT* SORT_DINT*

ARRAY_RANGE_DINT* LIFO_WRT_DWORD* SEARCH_GT_WORD SORT_WORD*

ARRAY_RANGE_DWORD* LIFO_WRT_INT* SEARCH_LE_BYTE TBL_RD_DINT*

ARRAY_RANGE_INT* LIFO_WRT_UINT* SEARCH_LE_DINT TBL_RD_DWORD*

ARRAY_RANGE_UINT* LIFO_WRT_WORD* SEARCH_LE_DWORD* TBL_RD_INT*

ARRAY_RANGE_WORD* SEARCH_EQ_BYTE SEARCH_LE_INT TBL_RD_UINT*

FIFO_RD_DINT* SEARCH_EQ_DINT SEARCH_LE_UINT* TBL_RD_WORD*

FIFO_RD_DWORD* SEARCH_EQ_DWORD* SEARCH_LE_WORD TBL_WRT_DINT*

FIFO_RD_INT* SEARCH_EQ_INT SEARCH_LT_BYTE TBL_WRT_DWORD*

FIFO_RD_UINT* SEARCH_EQ_UINT* SEARCH_LT_DINT TBL_WRT_INT*

FIFO_RD_WORD* SEARCH_EQ_WORD SEARCH_LT_DWORD* TBL_WRT_UINT*

FIFO_WRT_DINT* SEARCH_GE_BYTE SEARCH_LT_INT TBL_WRT_WORD

FIFO_WRT_DWORD* SEARCH_GE_DINT SEARCH_LT_UINT*

FIFO_WRT_INT* SEARCH_GE_DWORD* SEARCH_LT_WORD

FIFO_WRT_UINT* SEARCH_GE_INT SEARCH_NE_BYTE

ABS_DINT* ADD_UINT* MOD_DINT MUL_REAL SUB_DINT

ABS_INT* DIV_DINT MOD_INT MUL_UINT* SUB_INT

ABS_REAL* DIV_INT MOD_UINT* SCALE_DINT*P SUB_REAL

ADD_DINT DIV_MIXED* MUL_DINT SCALE_INT SUB_UINT*

ADD_INT DIV_REAL MUL_INT SCALE_UINIT*P

ADD_REAL DIV_UINT* MUL_MIXED* SCALE_WORD
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P r og r am  F l ow

Re l a t i o na l

T i m e r  F u n c t i o n  B l o c k s

CALL ENDMCR JUMP LABELN V_WIRE

COMMENT ENDMCRN JUMPN MCR

END H_WIRE LABEL MCRN

CMP_DINT* EQ_UINT* GT_REAL LT_INT RANGE_DINT

CMP_INT* GE_DINT GT_UINT* LT_REAL RANGE_DWORD*

CMP_REAL* GE_INT LE_DINT LT_UINT* RANGE_INT

CMP_UINT* GE_REAL LE_INT NE_DINT RANGE_UINT*

EQ_DINT GE_UINT* LE_REAL NE_INT RANGE_WORD

EQ_INT GT_DINT LE_UINT* NE_REAL

EQ_REAL GT_INT LT_DINT NE_UINT*

OFDT_HUNDS ONDTR_HUNDS TMR_HUNDS TOF

OFDT_SEC* ONDTR_SEC* TMR_SEC* TON

OFDT_TENTHS ONDTR_TENTHS TMR_TENTHS TP

OFDT_THOUS ONDTR_THOUS TMR_THOUS
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F B D  E D I T O R
The Function Block Diagram (FBD) editor is used to create logic with the Function 
Block Diagram programming language. FBD is a process language.  FBD logic 
graphically represents the programmed actions performed by a PLC as it executes.

The FBD editor is free form; that is, instructions and text boxes can be placed 
anywhere on the FBD editor where there is empty space. Sequences of instructions 
can be wired together horizontally and vertically. 

You can work with the FBD editor while offline to edit a disk copy of a project, or 
you can edit an FBD block of logic online, but this causes the logic to become not 
equal until you download the FBD block.

You can customize the appearance and behavior of the FBD editor by setting 
options (see page 23).

An FBD block is a named section of FBD Logic that is compiled and downloaded 
to the PLC represented by the associated target.

T o  c u s t o m i z e  t h e  F BD  ed i t o r
1. In the Options tab of the  Navigator, expand the Editors folder, then expand the Function Block Diagram 

folder.

2. Right-click the  Colors and Preferences page and choose Properties. 

The configurable settings appear as properties in the Inspector.

3. In the  Inspector, adjust settings as required. 

T o  c r ea t e  a n  F B D  b l o c k
1. In the Project tab of the  Navigator, right-click the Program Blocks folder, point to New, and then 

choose FBD Block. 

A new FBD block with a default name is created.

2. Rename the block as desired.

 Navigator: Project tab

An FBD Block
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T o  o p e n  a n  F B D  b l o c k  f o r  e d i t i n g
• In the  Project tab of the  Navigator, double-click an FBD block.

The block opens in the FBD editor.

Note: You can have multiple blocks open for editing. To navigate to another open 
FBD block, click the tab that displays its name at the top of the editor window.

W o r k i n g  w i t h  t h e  F B D  E d i t o r  O f f l i n e

While in offline mode, there is no live communication between the FBD editor 
and the target. Most logic development is done while offline. The following 
diagram illustrates some of the more common operations you can perform using 
the FBD editor offline.
 

Insert 
instructions and 
Text boxes from 
the Toolchest or 
right-click in the 
FBD editor

Drag variables 
from the 
Navigator into 
the FBD editor

Right-click in an 
empty space in the 
FBD editor and 
choose an 
instruction to insert 

Use the 
Inspector to edit 
the number of 
inputs for some 
FBD instructions

The Companion 
automatically 
provides 
information on 
what you click

Drag FBD instructions 
from the Toolchest 
into an empty space 
in the FBD editor

Hover over a 
variable to see 
information related 
to the variable

Click a connection 
point of an instruction 
to draw a wire from 
one instruction to 
another

Displays a list of the 
places the selected 
variable is used or a 
list of the blocks the 
selected block is 
called from
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T o  i n s e r t  a n  i n s t r u c t i o n
1. In the FBD editor, right-click an empty cell and choose Insert Instruction.

A smart list appears listing all available instruction mnemonics.

2. Choose an instruction mnemonic from the list and press ENTER. 

T o  a s s i g n  a  p a r a m e t e r  b e s i d e  a n  i n s t r u c t i o n  
There are two methods to assign a parameter to an instruction.

First method (from the FBD editor)

1. In the FBD editor, hover the mouse pointer immediately before an input connection point or immediately beyond an 
output connection point of an FBD instruction, so that the mouse pointer appears as .

2. Double-click the connection point.

3. In the smart list that appears, enter or choose an existing variable, constant, or expression to assign to the 
instruction parameter.

In the FBD editor, the instruction may display as follows:

Note: Inside the rectangle of the ADD instruction, the “1“ indicates the solve order 
of the instruction. Under the variable myCounter, the “1“ is the initial value of 
myCounter.

Second method (outside the FBD editor)

1. In the Variables tab of the Navigator, or the Data Watch tool, select a variable.

The mouse pointer indicates that a 
parameter can be assigned to this 
connection point beside the ADD 
instruction

This ADD instruction requires two 
inputs (at IN1 and IN2)

This ADD instruction requires one output 
(at Q)

The numeral 1 indicates that for this FBD 
block, this instruction is solved first
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FBD Editor5
2. Drag the selected variable to the connection point of an FBD instruction.

3. When the mouse pointer appears as , release the left mouse button to assign the variable to a parameter of the 
FBD instruction.

For example, the following diagram shows that you can assign a parameter to the 
FBD SUBTRACT instruction at the output connection point named Q.

After you have assigned the parameter, the instruction may appear as follows:

Note: In the above diagram, “61“ is the initial value of myResult. “4“ inside the 
rectangle of the FBD instruction indicates its solve order.

Want to know more? From the Help menu, select Search. Look up “solve order”. Select “FBD 
Editor: an Overview“.
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T o  a s s i g n  a  p a r a m e t e r  a b o v e  a n  F B D  i n s t r u c t i o n  o r  f u n c t i o n  b l o c k  i n s t a n c e
The FBD Call instruction and every function block instance (an instance of a 
counter, PID, timer, HART utility, or user-defined function block) require a 
parameter to be assigned immediately above the instruction or instance.

1. In the FBD editor, hover with the mouse pointer immediately above an FBD Call or function block instance so that the 
mouse pointer appears as .

2. When the mouse pointer appears as , click the left mouse button.
The instruction or function block instance appears in the FBD editor with the 
parameter selected, as shown below.

3. Without moving the mouse pointer, click again.

A smart list appears. If this is an FBD Call instruction, the smart list contains a list of 
all callable blocks of logic in your target. If this is an FBD function block instance, 
the smart list contains a list of variables that you can choose from to assign 
instance data to the function block instance. Normally you would choose or create 
instance data that is not used by any other function block instance, but you can 
assign the same instance data to multiple function block instances if you want.

4. In the smart list, enter or choose an existing block of logic, or enter a new variable, or enter or choose an existing 
variable.
The block appears as the destination of the FBD Call or the variable is assigned as 
instance data to the function block instance.

To  c h e c k  ( v a l i d a t e )  a  s i n g l e  FB D  b l o c k
1. In the Project tab of the Navigator, expand the target that contains the block to check, and then 

expand the Logic folder.

2. Expand the Program Blocks folder and then, if the block resides in a user-defined folder, expand the user-
defined folder.

3. Right-click the block and choose Check Block.

Machine Edition checks the block for errors. Any messages or errors are displayed 
in the Build tab of the Feedback Zone.
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To change the number of inputs for FBD instructions (ADD, AND, MUL, OR, SUB, XOR)
1. In the FBD editor, select an ADD, AND, MUL, OR, SUB, or XOR instruction.

2. In the Inspector, select the Number of Inputs property, and then enter or choose from the list the number of inputs 
you need.

3. If required, draw a wire or assign a variable or constant to the input and output parameters.

To  d r aw  a  w i r e
Notes:

■ At least two instructions must exist in the FBD editor.

■ You cannot draw a wire to or from a Text box.

1. In the FBD editor, hover the mouse pointer above a connection point of an FBD instruction or function block instance.

When the mouse pointer appears as , you can start a wire. See the diagram 
below.

2. Hold down the left mouse button, and then drag the mouse pointer to a connection point of another FBD instruction

3. Continue to hold down the left mouse button and drag the mouse pointer to a connection point of another FBD 
instruction, until the mouse pointer appears as . 
This indicates that the current location is a valid end point for the wire. See the 
diagram below. 

4. Release the left mouse button. 

Want to know more? In the online help index, look up “FBD Block”. Click the Related Topics 
button and choose “FBD PLC logic: an Overview“.
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The newly drawn wire appears as a solid (analog) or a dashed (discrete) line in the 
FBD editor. See the diagram below.

Note: In the above diagram:
■ The numbers “1“ and “2“ inside the rectangles have been reversed, indicating a 

change in the solve order.
■ The zeroes under the wire are the value that is travelling over the wire. It’s the 

same value at both ends.

T o  n e g a t e  a n  F BD  p a r a m e t e r
(For discrete parameters only.)

1. In the FBD editor, assign a BOOL parameter to a connection point of an FBD instruction that requires a BOOL 
variable. 
The diagram may appear as shown below.

2. Right-click a BOOL variable assigned to a connection point, for example, in the diagram above, BOOL1.

3. In the list box that appears, choose Negate. The diagram now appears as shown below.

Note: Negating a BOOL parameter while online causes logic to be not equal; 
turning a BOOL parameter ON/OFF while online does not affect logic equality.

T o  n e g a t e  a n  F BD  w i r e
(For discrete FBD wires only.)

1. If required, draw the FBD wire from a connection point that requires a BOOL variable, to a connection point that also 
requires a BOOL variable.

If the wire is discrete, it appears as a dotted line .

2. Right-click the wire, and then choose Negate.

The wire now appears as .
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T o  m o v e  o r  d u p l i c a t e  F B D  l o g i c
1. In the FBD editor, select an FBD instruction or Text box.

2. To move it:

■ Click the selection and drag it to a new valid location. When you move an 
instruction, the parameters and wires assigned to it move along with it.

- or -
To duplicate it:

Press CTRL while clicking the selection and drag the selection to where you want to 
place the duplicate. When you release the mouse button, a duplicate copy of the 
selected instruction is placed in the new area. When you duplicate an instruction, 
its parameters are also duplicated; wires are not duplicated.  

T o  z o o m  i n  o r  z o om  o u t  a n  F B D  b l o c k
Note: To zoom in an FBD block display in the FBD editor makes the FBD appear 
larger; to zoom out an FBD block display makes the FBD appear smaller.

1. Click anywhere in the FBD editor.

2. Do one of the following:

■ In the Inspector, expand the Diagram Settings group of properties, and then 
set the zoom property.

     - or -

■ To zoom out, press the “-“ key. To zoom in, press the “+“ key.

Want to know more? From the Help menu, select Search. Paste “editing FBD blocks“ 
(including the quotation marks) and then choose “Editing FBD blocks (PLC)“.
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W o r k i n g  w i t h  t h e  F B D  E d i t o r  O n l i n e

When online in monitor mode, you can monitor the PLC but cannot change 
anything in the PLC or edit your logic. 

When you are online in programmer mode, you can edit your logic, make changes 
in the PLC, and monitor the PLC. GE Fanuc PACSystems targets also support Run 
Mode Store; that is, they support the downloading of logic to a running target.

See “Offline, Online: monitor mode, programmer mode”, on page 39.

 

T o  t u r n  o n /o f f  o r  f o r c e  a  v a r i a b l e
• In the FBD editor, right-click a BOOL variable anywhere in FBD logic and choose Force ON, Force OFF, Toggle 

Force, Turn ON, Turn OFF, or Toggle IO. 

Online Status 
is indicated 
by the color 
of the target 
icon.

Text box for 
comments

Monitor and change 
values in real-time 
with the Data Watch 
tool.

 Feedback Zone indicates 
the status of the PLC. 

A wire with a solid 
line indicates analog

PLC status is indicated 
in the status bar.

Right-click a 
variable to 
force it. 

PLC status 
and sweep 
time are 
displayed 
in real-
time in the 
Inspector.

Online indicator

Online status is indicated by the 
lightning bolt.

A wire with a dotted 
line indicates discrete

Companion 
Help for 
whatever 
you click on
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Note: Forcing a variable ON or OFF overrides any actions the logic may take 
during runtime. That is, if a variable is forced OFF (0), but FBD logic is trying to 
turn it ON (1), it stays OFF. 

F B D  I n s t r u c t i o n s ,  F u n c t i o n s ,  a n d  F u n c t i o n  B l o c k s

(PACSystems only.) The following is a list of all FBD instructions, functions, and 
function blocks available in Logic Developer - PLC. 

A d v a n c ed  M a th

B i t  Ope r a t i o n s

C o m p a r i s o n

C o n t r o l

C ou n t e r s

Want to know more? From the Help menu, select Search. Enter “Working with Variables and 
FBD Logic - Online (PLC)“ (including the quotation marks).

Want to know more? In the online help index, look up “Instructions (PLC FBD)“.

ABS ASIN COS EXPT LOG TAN

ACOS ATAN EXP LN SIN

AND OR ROR SHIFTR

NOT ROL SHIFTL XOR

CMP GE LE NE

EQ GT LT RANGE

DO_IO PID_IND SUS_IO SVC_REQ

MASK_IO_INTR PID_ISA SUSP_IO_INTR

DNCTR UPCTR
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FBD Editor
D a t a  M o v e

M a th

P r og r am  F l ow

T i m e r  F u n c t i o n  B l o c k s

T yp e  Co n v e r s i o n

BUS_RD BUS_RMW_WORD BUS_WRT

BUS_RMW_BYTE BUS_TS_BYTE COMM_REQ

BUS_RMW_DWORD BUS_TS_WORD MOV

ADD MOD NEG SUB

DIV MUL SCALE

CALL

OFDT_HUNDS ONDTR_HUNDS TMR_HUNDS TOF

OFDT_SEC ONDTR_SEC TMR_SEC TON

OFDT_TENTHS ONDTR_TENTHS TMR_TENTHS TP

OFDT_THOUS ONDTR_THOUS TMR_THOUS

BCD4_TO_INT DINT_TO_BCD8 INT_TO_BCD4 REAL_TO_DINT UINT_TO_DINT

BCD4_TO_REAL DINT_TO_DWORD INT_TO_DINT REAL_TO_INT UINT_TO_INT

BCD4_TO_UINT DINT_TO_INT INT_TO_REAL REAL_TO_UINT UINT_TO_REAL

BCD8_TO_DINT DINT_TO_REAL INT_TO_UINT TRUNC_DINT UINT_TO_WORD

BCD8_TO_REAL DINT_TO_UINT INT_TO_WORD TRUNC_INT WORD_TO_INT

DEG_TO_RAD DWORD_TO_DINT RAD_TO_DEG UINT_TO_BCD4 WORD_TO_UINT
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I L  E D I T O R
Instruction List (IL) is a programming language specified by the IEC 61131-3 
standard. This text language is accumulator-based and much like the assembly 
languages used for programming microprocessors. The instructions executed by an 
IL block modify or use an accumulator that is located in PLC memory. Two types of 
accumulators are defined: one analog accumulator for numeric and bitwise 
operations and eight boolean accumulators for discrete logic to support eight 
levels of nested boolean expressions. The IL editor is free-form with an option to 
apply a standard formatting rule. The appearance and behavior of the IL editor is 
user-configurable. 

Note: Only Series 90-30, VersaMax PLCs, and VersaMax Nano/Micro support IL 
logic.

T o  c o n f i g u r e  a c c u m u l a t o r s
1. In the Project tab of the  Navigator, right-click the  Program Blocks folder and choose Properties. 

The Inspector displays the Accumulator Address properties.

2. In the Boolean Start property, enter the reference address of the first of eight PLC memory locations to use for 
boolean accumulators.

The ending address is calculated automatically. The memory area must be %T, 
%M, or %Q. 

3. In the Analog Start property, enter the PLC memory locations to use for the analog accumulator.

The ending address is calculated automatically. The memory area must be %R, 
%AI or %AQ. 

T o  c r ea t e  a n  I L  b l o c k
1. In the Project tab of the  Navigator, right-click the  Program Blocks folder, point to New, and choose IL 

Block.

An empty IL block with the default name ”ILBkn” is added to the folder, where n 
represents a unique number.

2. Rename the block as desired. 

T o  o p e n  a n  I L  b l o c k  f o r  e d i t i n g
• In the Project tab of the  Navigator, right-click an IL Block and choose Open.

The block opens in the IL editor. 

Navigator: Project tab

An IL Block
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Note: You can have multiple blocks open for editing. To navigate to another open 
IL block, click the tab displaying its name at the top of the editor window.

W o r k i n g  w i t h  t h e  I L  E d i t o r  O f f l i n e

Most project development is carried out while offline from the target PLC. Editing 
while offline provides maximum flexibility and enables you to interact with the 
Machine Edition tools as shown in the following diagram.

T o  i n s e r t  a n  i n s t r u c t i o n
1. In the IL editor, right-click and choose Insert Keyword.

A smart list appears listing all available instruction mnemonics.

2. From the list, select an instruction and press ENTER.

The instruction is inserted in your logic.

T o  a s s i g n  o p e r a n d s  t o  a n  i n s t r u c t i o n
1. In the IL editor, right-click and choose Insert Variable.

A smart list appears showing all your defined variables.

Right click in 
the IL Editor 
to insert an 
instruction or 
variable.

The Variables tab of 
the Navigator lists all 
the variables in your 
projects.

A description of a 
variable pops up when 
you hover the mouse 
over it.

The Build tab of the 
Feedback Zone lists 
error messages 
when you validate.

The Companion 
provides information 
on what you click.

Drag and drop 
variables into the IL 
editor.

Configure the 
accumulators in the 
Inspector.
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IL Editor5
2. Type, or choose from the list, a variable name or reference address and then press ENTER.

The name appears in your logic.

Note: If you entered a reference address or a new variable name, you must create 
a variable from it.

T o  c r ea t e  a  va r i a b l e  f r o m  a  r e f e r e n c e  a d d r e s s
• In the IL editor, right-click a reference address, point to Create “name” as, and then choose a data type.

A variable is created and a default name is applied. For example, if the reference 
address is %R0032, the auto-created variable is named R00032.

T o  c r ea t e  a  va r i a b l e  f r o m  a  n a m e
1. In the IL editor, right-click a name, point to Create “name” as, and then choose a data type.

A variable is created with the name you right-clicked. 

2. Map the variable to PLC memory. (See page 21.)

T o  m o v e  o r  d u p l i c a t e  I L  l o g i c
1. In the IL editor, select a range of logic.

2. To move it, click the selection and drag it to a new location. To duplicate it, press CTRL while clicking the selection, and 
drag the selection to where you want to place the duplicate.

When you release the mouse button, the selection is respectively moved to the 
new location or a duplicate copy of the selected logic is placed in the new area. 

T o  i n s e r t  a n  i n l i n e  c om m en t
1. In the IL editor, click where you want to insert an inline comment.

2. Type an apostrophe (‘) followed by comment text. 

3. Press ENTER to complete the comment.

T o  i n s e r t  a  b l o c k  c o m me n t
1. In the IL editor, click where you want to insert a block comment.

2. Type (* followed by comment text. 

A block comment can contain any number of characters and can span multiple 
lines.

3. Type *) to complete the block comment.

T o  r e f o rm a t  I L  l o g i c
• In the IL editor, right-click and choose Beautify Source.

The entire content of the IL editor is reformatted according to the default formatting 
(indentation) rules.
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W o r k i n g  w i t h  t h e  I L  E d i t o r  O n l i n e

When online in monitor mode, you can monitor the PLC but cannot change 
anything in the PLC or edit your logic. 

When you are online in programmer mode, you can monitor the PLC, edit your 
logic, and make changes in the PLC. Many GE Fanuc targets also support Run 
Mode Store; that is, they support the downloading of logic to a running target

See “Offline, Online: monitor mode, programmer mode”, on page 39.

T o  m o n i t o r  a  d a t a  v a l u e
• Click anywhere in the IL editor and hover the mouse pointer over a variable.

A tooltip appears, showing the variable’s current value. This value, however, does 
not update automatically: you must move the mouse pointer away and back over 
the variable to update the value.

T o  c h a n g e  a  B O O L  v a r i a b l e ’ s  s t a t e
• In the IL editor, right-click the BOOL variable whose value you want to change and choose Turn On, Turn Off, or 

Toggle IO.

The Feedback Zone 
indicates that a 
connection has been 
established with the 
PLC.

The 
Companion 
provides 
information 
on what you 
click.

Target icon 
changes to 
indicate 
status of the 
PLC. 

PLC status is 
indicated in the 
status bar.

Right-click a 
BOOL to 
change or 
force its state. 

Hover the mouse 
pointer over a 
variable to show a 
popup of its value.

Monitor and 
change variable 
values in the Data 
Watch.
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IL Editor5
The state of the variable in the target PLC changes when the command is received. 
It remains in that state until acted on by the PLC’s logic. 

T o  f o r c e  a  B OOL  v a r i a b l e ’ s  s t a t e
• In the IL editor, right-click a BOOL variable and choose Force On, Force Off, or Toggle Force. 

The state of a forced variable remains unchanged, regardless of any actions by PLC 
logic.

T o  r e mo v e  t h e  f o r c e  f r om  a  B O O L  v a r i a b l e
• In the IL editor, right-click a BOOL variable and choose Remove Forces. 

The state of the forced variable is controlled by PLC logic from now on.

D o w n l o a d i n g  O n l i n e  C h a n g e s  t o  a  T a r g e t  G E  F a n u c  P L C

You can change your IL logic while online, but you must download the changes to 
the PLC to maintain equality. Some GE Fanuc PLCs support the downloading of 
changed IL logic even when they are executing. 

T o  m a k e  c h a n g e s  t o  I L  l o g i c  a n d  d o w n l o a d  t h e m  t o  a  r u n n i n g  t a r g e t  P LC  ( i f  t h e  t a r g e t  P LC  s u ppo r t s  i t )
1. While online to a target PLC, make a change to IL logic.

2. In the  Project tab of the  Navigator, right-click the  target and choose Download to PLC.

You are prompted to confirm a Run Mode Store. That is, the altered IL block will be 
downloaded to the running PLC without stopping it. 

Want to know more? In the online help index, look up “Downloading to running GE Fanuc 
PLCs”.
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I L  I n s t r u c t i o n s

The following is a list of all IL instructions available in Logic Developer - PLC. 
Companion help indicates which PLCs support the instructions.

Bas i c  I n s t r u c t i o n s

A d v a n c ed  M a th

B i t  Ope r a t i o n s

C on t r o l

C on v e r s i o n s

C ou n t e r s

An asterisk (*) indicates the instructions exclusive to VersaMax PLCs. 

ADD GT LT OR ST_DINT XOR

AND LD_BOOL MOD ORN ST_INT XORN

ANDN LD_ENO MUL PT ST_REAL

DIV LD_INT NE R ST_WORD

EQ LDN_BOOL NOT S STN_BOOL

GE LE NT ST_BOOL SUB

ACOS COS LN SQRT_DINT TAN

ASIN EXP LOG SQRT_INT

ATAN EXPT SIN SQRT_REAL

AND_WORD BIT_SEQ MASK_COMP_DWORD OR_WORD SHIFTL_WORD

BIT_CLR_WORD BIT_SET_WORD MASK_COMP_WORD ROL_WORD SHIFTR_WORD

BIT_POS_WORD BIT_TEST_WORD NOT_WORD ROR_WORD XOR_WORD

DO_IO DRUM PID_IND PID_ISA SER SVC_REQ

BCD4_TO_INT DINT_TO_REAL RAD_TO_DEG REAL_TO_WORD WORD_TO_REAL

BCD4_TO_REAL INT_TO_BCD4 REAL_TO_DINT TRUNC_DINT

DEG_TO_RAD INT_TO_REAL REAL_TO_INT TRUNC_INT

DNCTR UPCTR
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D a t a  M o v e

D a t a  T a b l e

Ma th

P r og r am  F l ow

Re l a t i o na l

T i m e r  F u n c t i o n  B l o c k s

BLK_CLR_WORD BLKMOV_REAL COMM_REQ MOVE_BOOL MOVE_REAL SHFR_BIT
BLKMOV_INT BLKMOV_WORD MOVE_INT MOVE_WORD SHFR_WORD

ARRAY_MOVE_BOOL SEARCH_EQ_INT SEARCH_GT_DINT SEARCH_LT_BYTE SEARCH_NE_WORD

ARRAY_MOVE_BYTE SEARCH_EQ_WORD SEARCH_GT_INT SEARCH_LT_DINT

ARRAY_MOVE_DINT SEARCH_GE_BYTE SEARCH_GT_WORD SEARCH_LT_INT

ARRAY_MOVE_INT SEARCH_GE_DINT SEARCH_LE_BYTE SEARCH_LT_WORD

ARRAY_MOVE_WORD SEARCH_GE_INT SEARCH_LE_DINT SEARCH_NE_BYTE

SEARCH_EQ_BYTE SEARCH_GE_WORD SEARCH_LE_INT SEARCH_NE_DINT

SEARCH_EQ_DINT SEARCH_GT_BYTE SEARCH_LE_WORD SEARCH_NE_INT

ADD_DINT DIV_DINT MOD_DINT MUL_DINT SCALE_WORD* SUB_REAL

ADD_INT DIV_INT MOD_INT MUL_REAL SUB_DINT

ADD_REAL DIV_REAL MUL_INT SCALE_INT* SUB_INT

CAL CALCN END_MCRN JMPC MCRN RETC

CALC END JMP JMPCN RET RETCN

EQ_DINT GE_DINT GT_DINT LE_DINT LT_DINT NE_DINT RANGE_DINT

EQ_INT GE_INT GT_INT LE_INT LT_INT NE_INT RANGE_INT

EQ_REAL GE_REAL GT_REAL LE_REAL LT_REAL NE_REAL RANGE_WORD

OFDT_HUNDS ONDTR_HUNDS TMR_HUNDS

OFDT_TENTHS ONDTR_TENTHS TMR_TENTHS

OFDT_THOUS ONDTR_THOUS TMR_THOUS
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S T  E D I T O R
Structured Text logic is a programming language specified by the IEC 61131-3 
standard. The PLC Structured Text (ST) Editor is a free-form text editor for editing 
Structured Text logic in the Machine Edition environment. With the ST editor, you 
can work on a disk copy of a structured text block (offline) or monitor the 
execution of an ST block running in the PLC (online). You can edit an ST block 
online, but this causes the logic to become unequal until you download the ST 
block.

ST is a high-level language composed of various operators and functions. ST logic 
is supported by PACSystems PLCs.

T o  c u s t o m i z e  t h e  S T  E d i t o r
1. In the Options tab of the Navigator, expand the Editors folder and then the Text folder.

2. Right-click a page (Colors or Preferences), and choose Properties.
The configurable settings appear as properties in the Inspector.

3. In the Inspector, adjust the settings as required.

T o  c r ea t e  a n  S T  b l o c k
1. In the Project tab of the Navigator, expand the Logic folder, right-click the Program Blocks 

folder or a user-defined folder, point to New, and then choose ST block.
A new ST block with a default name is created under the Program Blocks folder or 
under a user-defined folder.

2. (Optional.) Rename the block.

T o  c r ea t e  a  p a r a m e t e r i z e d  S T  b l o c k
1. Create an ST block.

2. Do one of the following:

■ In the Inspector, set parameters for the block.
- or -

■ Set the block’s Block Type property to Parameterized Block, and then optionally 
schedule the parameterized block.

Notes: 

■ By assigning parameters to the block, its Block Type property is automatically 
changed to Parameterized Block.

Navigator: Project tab 

An ST Block
GFK-1918G Proficy Logic Developer - PLC 5.50 115
sales@roc-electric.com   www.roc-electric.com



L o g i c  P r o g r a m s  a n d  B l o c k s

ST Editor5
■ A parameterized block cannot have both interrupt scheduling and parameters. 

T o  o p e n  a n  S T  b l o c k  f o r  e d i t i n g
• In the Project tab of the Navigator, under the Logic folder, under the Program Blocks folder, or 

under a user-defined folder, double-click an ST block.

The ST block opens in the ST editor.

W o r k i n g  w i t h  t h e  S T  E d i t o r  O f f l i n e

The ST editor interacts with the Machine Edition tools to provide maximum 
flexibility when editing a program. The following diagram illustrates some of the 
operations you can perform.

Want to know more? In the online help index, look up “Parameterized Block (PLC)“.

Right-click in 
the ST Editor 
to insert an 
instruction or 
variable.

The Variables tab of 
the Navigator lists all 
the variables in your 
targets.

A description of a 
variable pops up when 
you hover the mouse 
pointer over it.

The Companion 
provides information 
on what you click.

Drag and drop 
variables into the ST 
editor.

Configure the 
variables in the 
Inspector.

The Build tab of 
the Feedback 
Zone lists error 
messages when 
you validate.

Right-click in the ST 
Editor to perform 
various operations.
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T o  i n s e r t  a n  S T  v a r i a b l e  o r  k e y w o r d
1. In the ST editor, right-click and choose Insert Variable or Insert Keyword. 

A smart list appears, prompting you to enter the name of an existing variable or 
keyword.

2. Type, or choose from the list, the item you want, and then press ENTER.
The variable or keyword appears in the ST editor.
Notes: 

■ Parameters and constants must be manually entered.

■ When entering an indirect reference as an operand, prefix the variable name 
with @ after selecting it from the smart list, for example, @IntVar. Indirect 
referencing is available for all register references (%R, %P, %L, %W, %AI, and 
%AQ). 

T o  c r ea t e  a  va r i a b l e  f r o m  a  n a m e
• In the ST editor, right-click a name that was entered as an operand, point to Create "[name]" as, and then choose 

a data type from the list that appears.
A new variable of the specified data type is created and substituted for the name at 
every occurrence in the ST block. The name of the new variable is identical with 
the original name.

T o  i n s e r t  a  l i n e  c o mm e n t
1. In the ST editor, click where you want a line comment to begin.

2. Type an apostrophe (’) or // followed by comment text.

3. Press ENTER to complete the line comment. The line comment ends when a new line starts.

T o  i n s e r t  a  b l o c k  c o m me n t
1. In the ST editor, click where you want a block comment to begin.

2. Type (* followed by comment text. A block comment can contain any number of characters and can span multiple 
lines.

3. Type *) to complete the block comment.

Want to know more? In the online help index, look up “Indirect References“.
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ST Editor5
T o  s e l e c t  a  r a n g e  o f  S T  l o g i c
1. In the ST editor, click at the beginning of the range.

2. Press and hold shift and then click at the end of the range. All logic within the range is selected.
Tips:

■ You can also click and drag from the beginning of the range to the end.

■ After selecting a range of logic, you can click anywhere in it and drag it to 
another area in the ST editor.

T o  m o v e  o r  d u p l i c a t e  S T  l o g i c
1. In the ST editor, select a range of logic.

2. To move it, click the selection and drag it to the new location. To duplicate it, press CTRL while clicking the selection, 
and then drag the selection to where you want to place the duplicate.
When you release the mouse button, the selection is respectively moved to the 
new location or a duplicate copy of the selected logic is placed in the new area.

T o  l o c a t e  a l l  o c c u r r en c e s  o f  a  va r i a b l e
1. In the Feedback Zone, click the References tab.

2. Click a variable anywhere it appears in  ST logic, in the Variables tab of the Navigator, or in the Data Watch 
tool.
Each occurrence of the variable in your project (for a given target) is listed in the 
References tab of the Feedback Zone.
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ST Editor
W o r k i n g  w i t h  t h e  S T  E d i t o r  O n l i n e

When online in monitor mode, you can monitor the PLC but cannot change 
anything in the PLC or edit your logic. 

When you are online in programmer mode, you can monitor the PLC, edit your 
logic, and make changes in the PLC. PACSystems also support Run Mode Store; 
that is, they support the downloading of logic to a running target.

See “Offline, Online: monitor mode, programmer mode”, on page 39.

T o  v i ew  a  v a r i a b l e  v a l u e
■ In the ST editor, hover the mouse pointer over a variable to see its value. A tool 

tip displays the variable name, address, description, data type, and current 
value. If this is a BOOL variable, the tool tip also displays if it has been forced 
On (1) or Off (0).

The Companion 
provides information 
on what you click.

Target icon 
changes to 
indicate 
status of the 
PLC. 

Right-click a 
BOOL to 
change or 
force its state. 

Hover the mouse 
pointer over a 
variable to  see its 
value in a tool tip.

The Feedback Zone 
indicates the results 
of an online 
operation.

The PLC status 
appears in the 
status bar.

Monitor variable 
values in the Data 
Watch. In online 
programmer mode, 
you can change the 
values

In online programmer 
mode, change a 
variable’s current 
value or current state 
in the Inspector.
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ST Editor5
T o  v i ew  t h e  v a l u e  o f  a n  S T  p a r a m e te r i z e d  b l o c k  p a r a m e te r
1. In the Project tab of the Navigator, expand the Program Blocks folder.

2. If the block that contains the call to the ST parameterized block whose parameter you want to monitor resides in a 
user-defined folder, expand the user-defined folder.

3. Right-click the block that contains the call and choose Open.
The block appears in the appropriate editor.

4. In the editor, right-click the block call to the ST parameterized block and choose Open Block.
The called ST parameterized block appears in the ST editor.

5. In the ST editor, hover the mouse pointer over the parameterized block parameter (variable) to see its value.
Depending on the context of the parameter, the tool tip displays the following 
items:

■ If the text refers to a parameter instead of a variable, and the block was opened 
from a CALL instruction (in an LD, ST, or FBD block), then if possible, the 
parameter is associated with the variable used in the call the block was opened 
from. In this case, the tool tip displays the parameter name, address of the 
variable, description of the parameter, data type, and value of the variable.

■ If the text refers to a parameter instead of a variable, and the block was not 
opened from a CALL instruction (in an LD, ST, or FBD block), then the tool tip 
displays the parameter name, description of the parameter, and data type only.

In either case, if this is a forced BOOL variable, the tool tip also displays if the 
variable has been forced On (1) or Off (0).

Note: The tool tip displays a variable’s current value only if logic is equal; the tool 
tip doesn’t display the current value if logic is not equal.

T o  c h a n g e  a  B O O L  v a r i a b l e ’ s  s t a t e
• In the ST editor, right-click the BOOL variable whose value you want to change and choose Turn On, Turn Off, or 

Toggle IO.

The state of the variable in the target PLC changes when the command is received.
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ST Editor
T o  f o r c e  a  B OOL  v a r i a b l e ’ s  s t a t e
• In the ST editor, right-click a BOOL variable and choose Force On, Force Off, or Toggle Force.

The state of a forced variable remains unchanged, regardless of any actions by PLC 
logic.

T o  r e mo v e  t h e  f o r c e  f r om  a  BOOL  v a r i a b l e
• In the ST editor, right-click a BOOL variable and choose Remove Forces.

The state of the unforced variable is controlled by PLC logic from now on.

S T  S t a t e m e n t s ,  F u n c t i o n s ,  a n d  F u n c t i o n  B l o c k s

The following is a list of all ST statements, functions, and function blocks available 
in Logic Developer - PLC. InfoViewer Help indicates which PLCs support the 
statements, functions, or function blocks.

S t a t em e n t s  

A d v a n c ed  M a th

B i tw i s e  O p e r a t o r s  

C on t r o l

Want to know more? In the online help index, look up “ST PLC Logic: an Overview”, and then 
click the “PLC“ link at the top, right corner.

:= (Assignment) Comment Function block invocation Repeat ... until

Block call Exit Function call Return

Case For ... do If ... then ... elsif While ... do

ACOS COS LN SQRT_DINT TAN

ASIN EXP LOG SQRT_INT

ATAN EXPT, **, or ^ SIN SQRT_REAL

AND NOT OR XOR

DO_IO MASK_IO_INTR SUS_IO SUSP_IO_INTR SVC_REQ SWITCH_POS
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ST Editor5
C on v e r s i o n s

D a t a  M o v e

Ma th

Re l a t i o na l  O pe r a t o r s

T i m e r  F u n c t i o n  B l o c k s

ANGLES INT to BCD4, DINT, REAL, UINT, or WORD

BCD4 to INT, REAL, or UINT REAL to DINT, INT, or UINT

BCD8 to DINT or REAL TRUNC_DINT, TRUNC_INT

DINT to BCD8, DWORD, INT, REAL, or UINT UINT to BCD4, DINT, INT, REAL, or WORD

DWORD to DINT WORD to INT or UINT

COMM_REQ

+ (addition) - (subtraction) - (negation) * (multiplication) / (division) mod (modulo)

ABS_DINT ABS_INT ABS_REAL SCALE_DINT SCALE_INT SCALE_UINT

= (Equal) >= (Greater than 
or equal)

> (Greater than) <= (Less than or 
equal)

< (Less than) <>, != (Not equal)

TOF TON TP
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C Blocks
C  B L O C K S
A C block is an independent section of executable code written in the C 
programming language that is downloaded to and executed on the target PLC. C 
blocks are created externally using GE Fanuc’s C Programming Toolkit and then 
imported into a project. A C block compiled for PACSystems has a .gefelf 
extension. A C block compiled for Series 90-70 or Series 90-30 has a .exe 
extension. C Blocks can be called as a subroutine from another block (LD, ST, FBD,  
or IL) but cannot call another block.

For more information on developing C Blocks, refer to C Programmer’s Toolkit for 
Series 90 PLCs (GFK-0646) and PACSystems RX7i C Toolkit User’s Guide (GFK-
2259).

W o r k i n g  w i t h  C  b l o c k s

T o  i m p o r t  a  C  b l o c k
1. In the  Project tab of the  Navigator, right-click the Program Blocks folder and choose Add C block. 

The Open dialog box appears.

2. Browse to the .exe or .gefelf file you want to import and click Open.

The selected file is added to the Program Blocks folder with the same name as 
the .exe or .gefelf file.

Note: You can then move the C Block to a  user-defined folder. 

Want to know more? In the online help index, look up “C block” and “User-Defined Folder“.

 
Navigator: Project tab

A C Block
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C Blocks5
T o  s e t  a  C  b l o c k ’ s  p a r a me t e r s  
Note: This procedure applies only to C blocks that were written to require 
parameters for use on PACSystems or Series 90-70 targets.

1. In the  Project tab of the  Navigator, right-click the  C block and choose Properties. 

The  Inspector displays the block’s properties.

2. In the Inspector, select the Parameters property and click .

The Parameters dialog box appears.

3. Type a name and description for each required input and output parameter.

For information on the required parameters, refer to the written documentation for 
the C block. The names you enter will display in the CALL instruction that calls the 
C block. The names and descriptions will display in a tooltip when you hover the 
mouse pointer over the CALL instruction.

Want to know more? In the online help index, enter “Parameterized” and select the “C Block” 
help topic.
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C Programs
C  P R O G R A M S
Note: C programs are supported only on Series 90-70 CPUs, firmware release 6.00 
and later.

A C program is an independent section of executable code, written in C language, 
that is downloaded to and executed on the associated target PLC. To develop a C 
program, use GE Fanuc's C Programmer's Toolkit for Series 90 PLCs User's Manual 
(GFK-0646). You then import it into a project.

A C program has access to all the % reference tables of the PLC except for the 
_MAIN LD block’s %P memory and the %L memory of any other LD block. A C 
program can also call any of the numerous PLC-embedded functions that are 
included in the C Programmer’s Toolkit.

A C program cannot be called as a subroutine. Execution is controlled only 
through scheduling. A C program cannot call another block as a subroutine.

By setting the parameters of a C program, you enable it to access memory directly. 
When a C program begins to execute, it reads the data for all the parameters and 
makes a copy of the data. If the C program’s execution is interrupted or time-sliced 
over multiple scans, the C program, when it resumes execution, uses the copy of 
the data that it made when it began to execute. 

C programs can coexist with a main program and with State Logic on a Series 90-
70 PLC. For such a target, the State Logic is compiled into a C program. This C 
program is named _MAIN if there is no LD logic; however, if State Logic coexists 
with LD logic, the State Logic is compiled into a C program named _STATE and 
one LD block must be named _MAIN.

    Navigator: Project Tab

       A C Program
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C Programs5
W o r k i n g  w i t h  C  P r o g r a m s  

S e t t i n g  a  C  p r o g r am ’ s  p a r a m e t e r s  
Note: You must provide a list of all the input and output parameters that the C 
program requires. The main program does not use parameters.

1. In the  Project tab of the  Navigator, right-click a  C program and choose Properties.

The  Inspector displays the C program’s properties.

2. In the Inspector, select the Parameters property and click .

The Parameters dialog box appears.

3. On the Input and Output tabs, enter up to 8 input and up to 8 output parameters. Each parameter has its own row on 
the tab. For each parameter, double-click the following cells and enter the required data:
■ Name: The parameter’s name.

■ Type: The parameter’s data type.

■ Length: The length of the input or output reference.

■ Variable: The first data item associated with the parameter. 

■ Description: (Optional) The parameter’s description.

Want to know more? In the online help index, choose “C Program”.
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6 Ethernet Global Data (EGD)
Ethernet Global Data is a mechanism that enables one CPU, referred to as a 
producer, to share a portion of its internal memory with one or more other CPUs, 
referred to as consumers, at a regularly scheduled periodic rate. Such a snapshot of 
internal memory, mediated by an Ethernet interface, is referred to as an exchange. 
An exchange is identified by a unique combination of three identifiers:

✐ The Producer ID (the producer's IP address) 
✐ The Exchange ID (the exchange's identifier)
✐ The Adapter Name (the Ethernet interface identifier)

E x c h a n g e s  v s .  P a g e s

Some EGD tools group multiple produced exchanges into what is called a page, 
and some EGD tools can consume such pages. Logic Developer - PLC, however, 
does not consume or produce pages. It consumes and produces exchanges.

✐ When you add a consumed exchange in Logic Developer - PLC, if an EGD 
tool has published produced pages that contain multiple exchanges to the 
EGD Configuration Server, the produced exchanges are extracted from the 
pages and presented for your selection as exchanges.

✐ Logic Developer - PLC does not group multiple produced exchanges into a 
produced page. EGD tools that consume pages see the exchanges 
produced by Logic Developer - PLC as produced pages that contain only 
one exchange each.

I n t e g r a t i o n  w i t h  t h e  E G D  C o n f i g u r a t i o n  S e r v e r

Logic Developer - PLC is integrated with the EGD Configuration Server. The EGD 
Configuration Server is a central repository of EGD configuration information used 
to facilitate the sharing of information between EGD tools in order to assist with 
the configuration of EGD. 

After configuring a produced exchange on any EGD tool (such as the EGD 
component in Logic Developer - PLC), you can publish the configuration of the 
produced exchanges to the EGD Configuration Server. After this, Logic Developer - 
PLC, when connected to the server, can obtain the produced exchange 
configuration from the server and automatically create a consumed exchange that 
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matches the produced exchange exactly. At this point, the only thing left to do is to 
map the variables of the exchange to memory on the EGD consumer, or to replace 
some or all of the unmapped variables with mapped variables that already exist on 
the EGD consumer.

Using the EGD Configuration Server also provides you with extra EGD validation 
that is unavailable without the server. 

Using the EGD Configuration Server also enables you to use EGD Signatures. 
When a PACSystems is configured to use signatures, then every scan, it compares 
the signature of every consumed exchange with the signature of its corresponding 
produced exchange to determine whether the configuration of the consumed 
exchange matches the configuration of the produced exchange; if not, the 
exchange is not consumed. 

The EGD Configuration Server keeps track of which produced exchanges 
published on the server are consumed by EGD devices that are connected to the 
server. You can then obtain an Unconsumed Data report. You can also obtain 
reports that compare the produced or consumed exchange information on your 
computer with that on the server.

The EGD Configuration Server is not the authoritative source of the EGD 
configuration. It does not store past versions of EGD configurations. It contains 
only the latest snapshots of the EGD configurations published to it. The EGD tools 
are the authoritative source, while the server simply enables the tools to share 
information. It is possible to delete the server contents completely and restore 
them again by using the tools in a two-step process: publish the authoritative 
information from all the tools to the server, and then have each tool read the 
information it needs from the server and confirm to the server that it has received 
it.

I n t e g r a t i o n  w i t h  t h e  E G D  M a n a g e m e n t  T o o l  ( E M T )

Logic Developer - PLC is also integrated with the EGD Management Tool (EMT). 
You can open the EMT from within Logic Developer - PLC and vice-versa.

The EGD Management Tool (EMT) provides a high-level view of the EGD system 
published on the EGD Configuration Server, including a graphical display of 
individual EGD systems. The EMT provides validation of the EGD configuration. 

Want to know more? In the online help index, look up “Ethernet Global Data in Logic 
Developer - PLC: an Overview” and “EGD Configuration Server: Integration with Logic 
Developer - PLC”. 
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The EMT enables the EGD configuration of devices by launching the appropriate 
EGD Configuration Tool from the graphical display.

L o g i c  D e v e l o p e r  -  P L C  i m p l e m e n t a t i o n  o f  E G D :  T h e  E G D  
c o m p o n e n t

The first step in using Ethernet Global Data (EGD) in a GE Fanuc PLC or ENIU 
target is adding the EGD component. In a PLC target, you can do so even if the 
CPU presently configured in the target does not support EGD, as long as the target 
belongs to one of the PLC families that support EGD.

This flexibility enables you to start configuring EGD even if the hardware 
specifications of your system have not been determined.

T o  a d d  t h e  E GD  c o m p o n e n t
• In the Project tab of the Navigator, right-click a  GE Fanuc PLC target that belongs to one of the PLC or 

ENIU family types that support Ethernet Global Data (EGD), point to Add Component, and choose Ethernet 
Global Data.
The  Ethernet Global Data folder is added to the target. The folder contains an 
empty  Consumed Exchanges folder and an empty  Produced Exchanges 
folder.

Note: For Ethernet modules that support EGD uploads, the EGD component is 
automatically added when you upload the Hardware Configuration and EGD 
configuration. The EGD component is also automatically added to a target when 
you import a folder that contains an Ethernet Global Data (EGD) configuration or 
import a Hardware Configuration that contains an EGD configuration. In such 
cases, the Consumed Exchanges and Produced Exchanges folders are 
automatically populated.

T o  i n s t a l l  t h e  EG D  C o n f i g u r a t i o n  S e r v e r
1. Insert the Machine Edition 5.50 supplemental CD into the computer on which you want to install the EGD 

Configuration Server.
The computer must be connected to an Ethernet network. It may be local or 
remote.

2. On the Machine Edition 5.50 supplemental CD, navigate to the EGD Server and Tools folder. 

3. Double-click the EgdCfgServer Setup.msi file.

Want to know more? Refer to the online help in the EGD Management Tool.

Navigator: After the Ethernet Global Data 
component has been added to the target
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The EGD Configuration Server is installed on the computer. 
Note: The client library required for your copy of Logic Developer - PLC to 
communicate with the EGD Configuration Server is automatically installed as part 
of the installation of Logic Developer - PLC.

T o  i n s t a l l  t h e  EG D  M a n a ge m e n t  To o l  ( E M T )  o n  y o u r  c om p u t e r
1. Insert the Machine Edition 5.50 supplemental CD into your computer.

2. On the Machine Edition 5.50 supplemental CD, navigate to the EGD Server and Tools folder.

3. Double-click the EgdManagementTool Setup.msi file.
The EGD Management Tool is installed on your computer. 

T o  c o n f i g u r e  c o m mu n i c a t i o n s  w i t h  t h e  EG D  C o n f i g u r a t i o n  S e r v e r
1. In the  Options tab of the Navigator, expand the  Machine Edition folder. 

2. Right-click the  EGD page and choose Properties.
The  Inspector displays the EGD options.

3. In the Inspector, configure the Host Name option. For help on this or any option, select the option and look up the 
help that automatically appears in the  Companion. To open the Companion, press SHIFT+F11. 

4. (Optional.) Configure the Local Server Cache Path and Timeout options.

T o  c o n f i g u r e  a  L og i c  D ev e l o p e r  -  P L C  t a r g e t  t o  u s e  t h e  EG D  C o n f i g u r a t i o n  S e r v e r
1. In the Project tab of the Navigator, expand the target. 

2. Right-click the  Ethernet Global Data folder and choose Properties.
The  Inspector displays the folder's properties. 

3. Ensure that the Use Configuration Server property is set to True and configure the properties below it. 

T o  a d d  a  n e w  p r o d u c e d  e x c h an g e  a n d  c o n f i g u r e  i t
1. In the Project tab of the Navigator, expand the target’s  Ethernet Global Data folder.

2. Right-click the  Produced Exchanges folder and choose New.
A new produced exchange appears with a default name. The new produced 
exchange is  invalid.

3. (Optional.) Enter a name that is more meaningful than the default name.

4. Right-click the produced exchange and choose Properties. 
The  Inspector displays the exchange's properties. 

5. In the Inspector, configure the Destination property and other properties as required.
If the new produced exchange is now valid, its icon looks like this: .

6. In the Project tab of the Navigator, right-click the produced exchange and choose Configure. 
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The EGD Variable editor appears.

7. In the editor, use the buttons to add, insert, or delete rows.

8. For each row, define the Variable, Ref Address, Length, and/or Description parameters. When you have configured 
the target to use the EGD Configuration Server, you must specify a Variable for each row; you cannot use memory 
ranges that have no variables mapped to them. The Ignore parameter is available only for the Status. The Type 
parameter is read-only.
For help on the EGD Variable editor, click inside the grey space at the top and 
press F1. 

T o  p u b l i s h  a  t a r g e t ' s  p r od u c e d  e x c h a n g es  t o  t h e  E G D  C o n f i g u r a t i o n  S e r v e r ,  b y  u s i n g  t h e  Va l i d a t e  me t h o d
1. In the Project tab of the Navigator, right-click the target and choose Set as active target.

If the option is unavailable, the target has already been set as the active target.

2. Right-click the target and choose Validate.
Any errors found in the target's EGD configuration, Hardware Configuration, or 
logic are listed in the Build tab of the Feedback Zone. 

3. Correct any errors found and repeat step 2 of this procedure.

4. When the Build tab of the Feedback Zone displays no errors, click the Messages tab of the Feedback Zone. 
If the message "EGD Produced Data published" appears, the target's produced 
exchanges have been updated (published) from your computer to the EGD 
Configuration Server.

T o  p u b l i s h  a  t a r g e t ' s  p r od u c e d  e x c h a n g es  t o  t h e  E G D  Co n f i g u r a t i o n  S e r v e r ,  b y  u s i n g  t h e  B i n d  a nd  Bu i l d  me t h od
1. In the Project tab of the Navigator, right-click the target and choose Set as active target.

If the option is unavailable, the target has already been set as the active target.

2. Expand the target.

3. Right-click the Ethernet Global Data folder and choose Bind and Build.
Any errors found in the target's EGD configuration are listed in the Messages tab of 
the Feedback Zone. Some of these errors may pertain to consumed exchanges. If 
you want context-sensitive help on the errors, we recommend that you use the 
Validation method instead of the Bind and Build method. 
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4. If errors are found pertaining to produced exchanges, correct them and repeat step 3 of this procedure. 
The message "EGD Produced Data published" appears when the target's produced 
exchanges have been updated (published) from your computer to the EGD 
Configuration Server.
If an error is found pertaining to a consumed exchange, you typically need to 
synchronize the consumed exchange.

T o  s y n c h r o n i z e  a  c o n s u me d  ex c h a n g e  on  y ou r  c om p u t e r  w i t h  t h e  c o r r e s po nd i n g  p r od u c e d  e x c h a n g e  p u b l i s h e d  o n  
t h e  E G D  C o n f i g u r a t i o n  S e r v e r :

1. If any of the following conditions is true, validate the target that contains the producer. See “Validating a Target”, on 
page 39.) 

■ You have uploaded the Hardware Configuration and EGD configuration from 
the producer PLC to your computer

■ You have converted the target that contains the producer

■ You have deleted the Ethernet Global Folder from the target that contains the 
producer and added it again.

Validating the target that contains the producer updates the EGD Configuration 
Server with the produced exchange that this consumed exchange consumes.

2. In the Project tab of the Navigator, expand the target.

3. Expand the  Ethernet Global Data folder and then expand the  Consumed Exchanges folder.

4. If you have changed the Local Producer ID property of the producer that the consumed exchange consumes from, 
right-click the consumed exchange and choose Properties. Then, in the Inspector, set the Producer ID property on 
the consumed exchange to the same value as the new Local Producer ID.

5. In the Project tab of the Navigator, right-click the consumed exchange and choose Synchronize to Server.

Want to know more? In the online help index, look up “Developing EGD systems with the 
EGD Configuration Server: Possible work flow” and “Troubleshooting (PLC EGD)”.
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7 Motion Programming
Logic Developer - PLC supports motion programming for the DSM324i and 
Motion Mate DSM314 motion control modules. High performance, easy-to-use, 
these multi-axis motion control modules are highly integrated with the 
PACSystems RX3i and the Series 90-30 PLC logic solving and communication 
functions.

Both the DSM324i and the DSM314 (see page 68) supports 10 motion blocks, 40 
subroutines and a maximum total of 1000 motion program statements. Logic 
Developer - PLC, making motion programming possible, supports the following 
motion editors: 

 PLC Motion Editor

Local Logic Editor

CAM Editor

This chapter outlines basic procedures that will get you started with Logic 
Developer - PLC to create motion programs with these three motion editors. 

T o  a d d  a  M o t i o n  c o mp on e n t  t o  a  t a r g e t

• In the  Project tab of the  Navigator, right-click the  target, point to Add Component, and then choose 
Motion.

A  Motion Program node is added to your project. Included are empty  
Motion Blocks, Local Logic, CAM Profiles and CAM Blocks folders.

Navigator: Project tab

Motion Program

Target right-click menu
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M o t i o n  P r o g r a m m i n g

PLC Motion Editor7
P L C  M O T I O N  E D I T O R
Logic Developer - PLC includes a PLC Motion Editor, which enables you to create 
PLC Motion blocks for the DSM324i and the DSM314. This text-based editor is 
configurable as to its appearance and behavior. Comments and white space are not 
considered as PLC Motion block statements. The Motion block programming 
syntax is different from Local Logic syntax (see page 137).

T o  a d d  a  M o t i o n  B l o c k
1. In the  Project tab of the  Navigator, expand the Motion Program.

2. Right-click  Motion Blocks and choose New. 

A new empty PLC Motion block with a default name is added to your project.

3. Rename the block as desired.

T o  o p e n  a  m o t i o n  b l o c k  f o r  e d i t i n g
1. In the  Project tab of the   Navigator, expand the Motion Program.

2. Expand  Motion Blocks and double-click the  Motion Block you want to open.

The block opens for editing in the PLC Motion editor.

Navigator: Project tab

Motion Blocks
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PLC Motion Editor
W o r k i n g  w i t h  t h e  M o t i o n  E d i t o r

T o  i n s e r t  a  c o mm an d
1. In the Motion editor, right-click and choose Insert Keyword.

A smart list appears showing all available motion commands. 

2. Select the appropriate command from the smart list and press ENTER.

The command is placed in the motion editor. 

Want to know more? In the online help index, choose “PLC Motion Editor”.

Insert a PLC Motion 
command by 
choosing a keyword. 

Insert a PLC Motion 
variable by selecting 
a variable from the 
smart list. 

The Companion 
tracks all mouse 
clicks. 

The Feedback Zone 
indicates that a 
connection has been 
established with the 
PLC.
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M o t i o n  P r o g r a m m i n g

PLC Motion Editor7
M o t i o n  C o m m a n d s

ACCEL
The ACCEL statement sets the axis acceleration for subsequent moves 
and remains in effect in a given block unless changed. Note: If a move 
instruction is executed before ACCEL, the tag Acceleration is used.

BLOCK NUMBER Block numbers may be used as the destination of JUMP commands. 
Block numbers must be unique and can be between 1 and 65535. 

CAM The CAM statement starts CAM motion and specifies exit conditions.

CAM-LOAD CAM-LOAD loads a parameter register with the starting location for a 
CAM slave axis.

CAM-PHASE CAM-PHASE sets the phase for CAM commands.
CALL The CALL command executes another block as a subroutine

CMOVE The CMOVE command programs a continuous move using the specified 
position and acceleration mode.

DWELL DWELL causes motion to cease for a specified time period before 
processing the next command. 

ENDPROG The ENDPROG statement terminates a PLC Motion program definition.
ENDSUB The ENDSUB statement terminates a PLC Motion subroutine definition.

JUMP
Jump to a block number or a sync block within the current program or 
subroutine. The jump may be unconditional or conditional based on the 
status of a CTL bit. 

LOAD Initializes or changes a parameter data register with a 32-bit twos-
complement integer value.

PMOVE The PMOVE command programs a positioning move using the specified 
position and accelerator mode. 

PROGRAM
The PROGRAM statement is the first statement in a motion program. The 
program statement identifies the program number (valid range: 1 
through 10) and the axis configuration. Program definitions cannot nest. 

SUBROUTINE
The SUBROUTINE statement is the first statement in a motion 
subroutine. The subroutine statement identifies the subroutine number 
(valid range: 1 through 40) and the axis configuration.

SYNC BLOCK A sync block is a special case of a block number. A sync block can be 
used only in multi-axis programs.

VELOC
Sets the process VELOCITY used by subsequent motion program move 
commands and remains in effect until changed by another VELOC 
statement.
136 Proficy Logic Developer - PLC 5.50 GFK-1918G
sales@roc-electric.com   www.roc-electric.com
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Local Logic
L O C A L  L O G I C  
A Local Logic block runs synchronously with the Motion block, but is independent 
of the PLC’s CPU scan. This enables the DSM324i or DSM314 to interact much 
more quickly with motion I/O signals on its faceplate connectors than would be 
possible if the logic for the signals were handled in the _MAIN program running on 
the PLC.

Local Logic language uses free-form, text-based circuits and contains basic 
mathematical and logical constructs. The Local Logic syntax enables you to assign 
a variety of logic tasks to your motion programs while working in conjunction with 
PLC Logic programs and motion blocks to yield a flexible programming 
environment. Because it uses straightforward, understandable syntax, it is easy to 
gain proficiency with this editor.

The Local Logic programming language supports assignments, conditional 
statements, arithmetic, logical, and relational statements. Local Logic provides the 
user access to motion controller data, parameters using a fixed set of variables, 
control, and status bits:

■ Parameter data - accessible from Local Logic host PLC and motion blocks. The 
parameter data are similar to variables in a program.

■ CTL bits - enable the Local Logic block or host PLC to signal the motion block 
to start an event. 

■ Motion block numbers - the current block number can be used within the Local 
Logic block or host PLC to make an action occur only during a specific motion 
programming section.

T o  c r ea t e  a  L o c a l  L og i c  b l o c k  
1. In the  Project tab of the  Navigator, expand the Motion Program.

2. Right-click  Local Logic and choose New. 

A new  Local Logic block with a default name is created.

3. Rename the block as required. 

T o  o pe n  a  L o c a l  L og i c  b l o c k  f o r  e d i t i n g
• In the  Project tab of the  Navigator, expand the Motion Program and double-click the  Local Logic 

block. 

The Local Logic block opens for editing in the Local Logic editor.

Navigator: Project tab

Local Logic
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M o t i o n  P r o g r a m m i n g

Local Logic7
W o r k i n g  w i t h  t h e  L o c a l  L o g i c  E d i t o r

The Local Logic editor has its own distinctive syntax for constructing Local Logic 
blocks. 

T o  i n s e r t  a  L o c a l  L o g i c  c om ma n d
1. In the Local Logic editor, right-click and choose Insert Keyword.

A smart list displays all available Local Logic commands. 

2. Select the desired command in the smart list and press ENTER 

The command is inserted.

Note: You can drag variables from the Local Logic Variable Table (LLVT) to the 
Local Logic editor. 

Drag and drop 
variables from the 
Local Logic 
Variable Table 
(LLVW) into the 
Local Logic editor.

Right-click to 
choose 
commands 
from a list.
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M o t i o n  P r o g r a m m i n g
Local Logic
L o c a l  L o g i c  V a r i a b l e s

Local Logic is designed to complement a PLC’s logic and mathematical 
capabilities. Solving small Local Logic and mathematical sets requires a tight 
synchronization with the controlled motion. 

Logic Developer - PLC includes a table containing Local Logic variables, the Local 
Logic Variable Table (LLVT), that you can drag into your Local Logic blocks. As 
illustrated in the diagram below, the LLVT has several tabs that organize the 
variables by category:

T o  v i ew  t h e  L L V T
1. In the  Project tab of the  Navigator, expand the Motion Program. 

2. Right-click  Local Logic and choose Local Logic Variable Table. 

The “Which LLVT do you want?” help topic appears. 

3. Select Motion Mate DSM314 or DSM324i.

The LLVT appears in the Infoviewer, displaying variables or data in each tab are:

Axis 1 Variables specific to axis 1
Axis 2 Variables specific to axis 2
Axis 3 Variables specific to axis 3
Axis 4 Variables specific to axis 4
Global Global data such as module status code
CTL bits DSM general Control/Status bits
Parameter Registers DSM parameter data

Click a heading to 
sort the table in 
ascending order. 
Click again to sort 
descending.

Click a tab to view a 
group of variables

Right-click a name 
to copy it to the 
clipboard.
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Local Logic7
The table has six columns:

T o  i n s e r t  a  L o c a l  L o g i c  v a r i a b l e
1. In the Local Logic editor, right-click and choose Insert Variable.

A smart list appears prompting you to choose a Local Logic variable name. 

2. Select a variable in the list and press ENTER. 

The variable is inserted in your Local Logic.

Name Contains the variable name that is to be used within a 
Local Logic block

Type The data type for this variable. For example, 32-bit 
means that this variable is a 32-bit variable.

Group
The group this variable is placed in. For example, 
Faceplate I/O means that this variable refers to a point 
on the module faceplate.

Description
This column contains a textual description of the 
variable. When the user hovers the mouse pointer over 
the description, a tool tip displays the description.

R This column indicates if the variable can be read by a 
Local Logic block.

W This column indicates if the variable can be written by a 
Local Logic block.
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Local Logic
L o c a l  L o g i c  C o m m a n d s  a n d  O p e r a t o r s

Local Logic enables you to execute basic logic and mathematical functions on the 
DSM324i or Motion Mate DSM314 module. Commands use upper case characters 
only and are case sensitive.

ABS TRUE -(minus) <= (less than or equal to) 
BWAND FALSE / (divide) <> (not equal)
BWOR IF * (multiply)
BWXOR THEN :=(assign)
BWNOT END_IF >(greater than)
ON MOD < (less than)
OFF + plus >= (greater than or equal to)

Want to know more? In the online help index, choose “Local Logic: an Overview”.
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CAM Editor7
C A M  E D I T O R
The CAM editor is an accessory for Logic Developer - PLC motion programming 
that provides a means to create, edit, and manage electronic CAM profiles. Each 
CAM profile is a user-defined curve that specifies the response of a slave servo to a 
master position index. CAM profiles are referenced by name in the parent motion 
program and grouped into CAM blocks. Each block is intended for download to a 
specific motion module via its PLC controller. The hardware components are 
specified in the Hardware Configuration (HWC) of the parent target. 

You can reuse a CAM profile by including it in multiple CAM blocks. To include a 
CAM profile in a CAM block, see “To add an alias to a CAM block”, on page 144.

To  c r ea t e  a  CA M  b l o c k
1. In the  Project tab of the  Navigator, expand the  Motion Program.

2. Right-click  CAM blocks and choose New.

A new CAM block with a default name is created.

3. Rename the block as desired.

To  i m po r t  CAM b l o c k s
1. In the  Project tab of the  Navigator, expand the  Motion Program.

2. Right-click CAM blocks and choose Import from File.

The Open dialog box appears.

3. Browse to the CAM block you want to import (.csv or .txt file). 

4. Click Open. 

The imported block appears in your project. 

To  o p e n  a  C A M b l o c k  f o r  e d i t i n g
1. In the  Project tab of the   Navigator, expand the Motion Program.

2. Expand  CAM Blocks and double-click the  CAM block you want to open.

The block opens for editing in the PLC Motion editor.

Project Tab: Navigator

CAM profiles and CAM blocks
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CAM Editor
W o r k i n g  w i t h  t h e  C A M  E d i t o r

You can adjust the curves of your CAM profile to suit the specific needs of your 
project. With the CAM editor you create profiles by defining points on a 
master/slave position curve. Groups of adjoining points are allocated to sectors. 
Each sector is assigned a polynomial curve fit order (1,2,3) that specifies how the 
curve will be interpolated between points. 

T o  c r ea t e  a  CA M  p ro f i l e
1. In the  Project tab of the  Navigator, expand the  Motion Program.

2. Right-click  CAM Profiles and choose New.

A new CAM profile with a default name is added to your project.

Curves of the 
profile can be 
adjusted and 
edited 
graphically.

Secondary 
curves show 
the velocity, 
acceleration 
and jerk of 
the CAM 
profile.

CAM profile 
table enables 
numeric editing 
and curve order 
grouping.

The Companion 
tracks your 
moves and 
provides 
information on 
what you click.

Navigator 
displays CAM 
profiles and 
blocks.

Configure 
profiles and 
blocks in the 
Inspector.
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CAM Editor7
T o  c o n f i g u r e  a  C A M  p r o f i l e
1. In the  Project tab of the  Navigator, expand the  Motion Program.

2. Right-click  CAM Profiles, right-click a  CAM profile, and choose Properties.

The Inspector displays the properties of the CAM profile.

3. Adjust the properties of the CAM profile in the Inspector to specify its type and boundary conditions.

T o  e d i t  a  C A M  p r o f i l e  
1. In the  Project tab of the  Navigator, expand the  Motion Program.

2. Right-click  CAM Profiles and double-click a  CAM profile.

A graphical representation of your profile appears in the profile editor and a 
numeric representation appears in the profile table. 

3. Insert and move points in the profile editor or table.

4. Group points into sectors in the profile table and assign curve fit order to each sector.

To  a dd  a n  a l i a s  t o  a  CAM b l o c k  
Right-click method

1. In the Project tab of the  Navigator, expand the  Motion Program and expand CAM blocks. 

2. Right-click a  CAM block, point to Add Alias to, and then choose a profile.

Note: Aliases correspond to CAM profiles within CAM blocks. In order to create 
aliases for CAM blocks, you must have previously created CAM profiles.

Drag and drop method

1. In the Project tab of the  Navigator, expand the  Motion Program.

2. Expand  CAM Profiles and expand  CAM blocks.

3. Drag a CAM profile and drop it onto a CAM block.

The CAM profile is added to the CAM block.

Want to know more? In the online help index, choose “CAM”.
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29, 39, 49, 68
Logic Developer - State 1, 15
Logic Folder 76
Logic Printouts 47
Logic Programs and Blocks 75
Logicmaster 1, 15

M
Machine Edition 1, 11, 15, 38

Starting 13
Visual Style 23

Main Program 78
Blocks 76
Diagram 75
Downloading 77
Number of Blocks 78
Properties 79

Making Word-for-Word 

Changes 92
Mapping a Variable to a 

Terminal 61
Math Instructions

FBD 107
IL 114
LD 95
ST 122

Maximum Number of Blocks 78
Modbus Address Report 47
Modem 31
Modem Communication 34
Module Catalog 36, 55, 56, 58, 

73, 74
Modules

Copying 59
Moving 59

Monitor Mode 39
Monitoring

Values of Parameterized 
Block Parameters 
(ST) 120

Monitoring Data Values
FBD 105
IL 111
LD 89
ST 119

Motion 1, 15
Blocks 134
Editor 1, 133, 134
Program 77

Motion Block Report 47
Motion Blocks 75, 77
Motion Mate DSM314 68, 77, 78
Motion Program 78

Diagram 75
Motion Programming 133
Moving

FBD Logic 104
IL Logic 110
LD Logic 88
Modules 59
ST Logic 118
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N
Navigator 17, 46, 76
Negating

FBD Parameters 103
FBD Wires 103

Network Administrator 37
Network Interface Unit (NIU) 72
New Reference Assignment 23
NIU 72
Number of Blocks in the Main 

Program 78

O
Offline 39

FBD Editor 98
Going Offline from a 

Target 41
IL Editor 109
LD Editor 84
ST Editor 116

Online
FBD Editor 105
Going Online to a Target 40
IL Editor 111
LD Editor 89
ST Editor 119

Online Force Report 47
Online in Monitor Mode 39
Online in Programmer Mode 39
Opening a Project 16
Operands

Assigning to IL 
Instructions 109

Assigning Variables 86
Options Tab 46

P
PACSystems 78, 128

Downloading IP 
Addresses 36

LD Instructions Support 93
Setting Permanent IP 

Addresses 36
PACSystems RX3i 29

Illustration 49
Motion modules 68
Motion Program 78

PACSystems RX7i 29, 91
Adding Fan Kits 57
Configuring 53
Illustration 52

Pages (EGD) 127
Parameter Data (Local Logic) 137
Parameter Editor 37, 55, 69
Parameterized Block Parameters

Viewing Values (ST) 120
Parameterized Blocks 75, 76

Creating (ST) 115
Parameters

C Blocks 124
C Programs 126

Permanent IP Address
Setting for PACSystems 36

PLCs
Configuring 54
Families 31, 49
Family Property 31
Interacting with 39
Starting 43
Status 31
Stopping 43

Power Supply 72
Replacing 54

Primary HWC 62, 67
Setting Up for CPU 

Redundancy 64
Printing

LD Blocks 48
Reports 48

Produced Exchanges
Adding 130

Producers (EGD) 127
Product Authorization 5, 7
Proficy Logic Developer - PC 1, 

15
Proficy Logic Developer - PLC 1, 

15
Proficy Logic Developer - State 1, 

15

Proficy Motion 1, 15
Proficy View 1, 15
Program Blocks Folder 76
Program Flow Instructions

FBD 107
IL 114
LD 96

Programmer Mode 39
Programs 126

C. See C Programs
Comparative Diagram 75
Main. See Main Program
Motion. See Motion 

Program 75
Scheduling 78, 79
Types 75

Programs and Blocks 75
Project Tab 76
Projects

Creating 15, 49, 72
Downloading 41
Editing 15
Executing 43, 141
Importing Folders 16
Machine Edition 11
Opening 16
Uploading 41

Publishing
Target’s Produced Exchanges 

to EGD Configuration 
Server 131

Q
Quick Start 13

R
Racks 49, 72

Expansion 52, 53, 56
Replacing 56

Redisplaying Reports 48
Redundancy

Basic CPU 62
Configuring Systems 64
CPU Over Genius 62, 63
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Genius 62, 63
Wizards 64, 65

Redundancy Systems 62
Reference Address 19, 46, 85
Reference View Tables 46

Default 46
User-Defined 46
Working with 47

Reformatting IL Logic 110
Relational Instructions

FBD 106
IL 114
LD 96

Relational Operators
ST 122

Remote I/O 30, 49, 73
Configuring 1

Remote I/O Scanner 70
Adding 71

Removing the Force from BOOL 
Variables 112, 121

Replacing
CPUs 54
Power Supplies 54
Racks 56
Text 80

Reports 47
Address Use 47
Application Structure 47
CAM Profile 47
Conversion 33
EGD 47
Fault Table 44
Generating 47
Hardware Configuration 47
IL Block 47
LD block 47
Local Logic Block 47
Modbus Address 47
Motion block 47
Online Force 47
Printing 48
Redisplaying 48
Structured Text Blocks 47
Variables 47

Reports Tab 47, 48
Right-Click Menu

HWC 54
Target 39, 133

Run Mode 43
Run Mode Store 89, 90, 92
Rungs (LD Logic) 83
Run-time Destinations 29
Run-time Files 41

S
SBA 70
Scheduling

Blocks 79
Configuring 80
Programs 78, 79

Searching
Global Search 81
In One Block 80

Secondary HWC 62, 67
Configuring 66

Selecting
Range of ST Logic 118

Serial Communication 34
Series 90 Micro 29, 78, 91
Series 90-30 29, 53, 68, 78, 91, 

108
Motion Program 77

Series 90-30 Ethernet Network 
Interface Unit 29

Series 90-70 29, 53, 78, 79, 91, 
93, 125
C Programs 77
Remote I/O Scanner 29

Series 90-70 Genius Remote I/O 
Scanner 29, 70

Setting Access Control 80
Setting IP Addresses

Lower-End Series 90-30 38
PACSystems (Permanent) 36
Series 90-30 CPU364 37
Series 90-30 CPU374 37
Series 90-70 36
Temporary 34

Setting Parameters

C Blocks 124
C Programs 126

Setting Up
Primary HWC for CPU 

Redundancy 64
Signatures (EGD) 128
Slots 52, 54
Software Key 6
Specialty Function Blocks 76
ST Blocks 76

Creating 115
Editing 116

ST Editor 1, 115
Customizing 115
Offline 116
Online 119

ST Function Blocks
Timer Function Blocks 122

ST Functions
Advanced Math 121
Bitwise Operators 121
Control 121
Conversions 122
Data Move 122
Math 122
Relational Operators 122

ST Instructions
Inserting 117

ST Logic 115
Duplicating 118
Moving 118
Selecting Range of 118

ST Statements 121
Starting a PLC 43
Starting Machine Edition 13
Statements (ST) 121
Status Bar 40
Stop Mode 43
Stopping a PLC 43
Structured Text Blocks 47
Sweep Time 31
Symbolic Variables 19
Synchronizing

Consumed Exchanges 
(EGD) 132
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HWCs 67, 69
System Requirements 3

T
Table of Contents 28
Target Properties 31
Targets 76

Adding 30
Adding GE Fanuc Remote 

I/O 72
Configuring 31
Converting 32
Definition 29
Downloading 41
GE Fanuc 29
Going Offline 41
Going Online 40
Offline 39
Online in Monitor Mode 39
Online in Programmer 

Mode 39
Remote I/O Scanner 70
Right-Click Menu 39, 133
Run Mode 43
Stop Mode 43
Uploading 42
Validating 39

Technical Support 8
Templates 15, 30, 72
Terminal 60
Test Edit 90
Text

Replacing 80
Timer Function Blocks

FBD 107
IL 114
LD 96
ST 122

Toolchest 17

Tools 17
Docking Markers 18

Transacted Online Programming 
(LD) 90

U
Unconsumed Data Report 

(EGD) 128
Uploading from a Target 42
URL 31
User-Defined Folders

Creating 79
User-Defined Function Blocks 76
User-Defined RVTs 46

Creating 46
Using Help

Companion Help 24
Favorites 27
Full-text Search 26
Help Index 25
InfoViewer Help 24
Table of Contents 28

Using Templates to Create 
Projects 15

V
Validating

FBD Blocks 101
LD Blocks 86
Targets 39

Variables 19, 33
Aliasing 21
Arrays 20
Bit References 22
Compound Structures 20
Creating 21
Creating from Names

(IL) 110
(ST) 117

Creating from Reference 
Addresses (IL) 110

Editing 20
I/O 19, 60
Inserting (ST) 117
Locating All Occurrences 

of 118
Mapping 21
Symbolic 19
Turning On or Off 105

Variables Reports 47
VersaMax 91

Adding Carrier/Base to 
Remote I/O 73

Configuring Remote I/O 72
VersaMax Ethernet RIOs 29
VersaMax Genius RIOs 29
VersaMax Micro 78
VersaMax Nano 78
VersaMax Nano / Micro 29, 91, 

108
VersaMax PLCs 29, 78, 108
VersaMax Profibus RIOs 29
VersaMax Remote I/O 72
VersaPro 1, 15
View 1, 15
Viewing Fault Table Reports 44
Viewing. See also Monitoring
Visual Style 23

W
Windows Explorer 17
Wires

Drawing in FBD 102
Negating 103

Word-for-Word Changes 40, 90
Making 92

Working with Reference View 
Tables 47
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